10w Falcon Controller- PLEASE HELP! Newbie!

Hello all!
I had purchased a Creality 10w Kit with Falcon Controller, installed it on a larger platform I had, rather than my 3D printer. It has TWO Y-axis motors and one X. The controller only has one plug for the Y-axis. I married the two Y-axis to one plug like a y harness. I fire it up, try to move it manually from the PC, and it just moves maybe 15mm. It acts as if the motors aren’t wired properly the way it sounds. Both y axis motors are moving in the same direction.
I have not updated any firmware as the link in the manual does work. Don’t really see any definitive software on their site either. I do t know my way around Lightburn too much. Is there some commands I need to change? Will it just not work with two motors in the Y-axis? The platform used to be 12v. Not sure if the motors that were on it are specific to 12v because the Creality stuff is 24v. Any guidance would be GREATLY APPRECIATED!

It’s not clear from this if this by itself is a problem. What are you doing to move the laser and what are you expecting to happen?

What do you hear and what is the problem it’s posing?

Is this good or bad?

There’s unlikely to be a software configuration for a hardware solution that you’ve created since you’re saying the controller itself only has provision for a single Y output.

How is the X motor behaving?

Hi Berainlb, I’m glad you’re helping! Was hoping you would respond.
I am moving it by manually selecting with my cursor where I want it to go. It will try to go there, but move very roughly and loud like it’s off track/ grinding. If I try to home it, it just jumps a few mm toward the back right I believe. Yes it’s good that the y axis motors are moving in the same directions rather than opposite which would try to “twist” the x-axis rail. Is it possible to send you a video or pictures?

With Creality 3D printers with one z-axis motor, I buy the dual z-axis upgrade with dual motors, and the kit comes with a y-harness for the two motors to plug into one spot. So I figured is they were wired in parallel, they would operate just fine?

You can put it onto a cloud service and then link here.

Does X axis behave as you’d expect?

If you disconnect one of the Y motors does the one motor behave normally? If so, can you test each motor independently to make sure they’re both working as you’d expect?

The typical concerns with something like this include:

  1. motors not working in the expected direction. This doesn’t seem to be an issue based on what you’re saying.
  2. inadequate current due to splitting the connector. This would be my first reaction if other things are working correctly but your symptoms don’t quite fit so not sure. If each motor works independently then this is the likely situation.

In principle the approach can work and isn’t uncommon.

What is the best method for me trying to manually move the x axis only? I will double check, but I think it is twitchy as well. I’ve tried unplugging just one of the y-axis motors and still get little irrational movement. I will test again. How can I upload pics or video to this conversation? I don’t see an option. I’ll look again, or ask my son

Use jogging controls in Move window.

Pictures can be directly uploaded by either drag-and-drop or by pushing the upload button on the form toolbar. Videos cannot be directly uploaded. You will need to link to an external site for that.

Ok! Let me check the “move” window and test just the x-axis. I will make a link and post a video momentarily. I really appreciate you helping me through this. Is there any link to firmware I should download? Grbl? GitHub?

I’m not particularly familiar but one other user just recently resolved an issue with homing by downgrading firmware:

I had to request the older firmware directly from Creality support. It’s not downloadable.

Let me know if this works! Thank you!

That’s great! Are you able to provide the firmware? Do you have a similar setup as me? With a bigger build platform and dual y-axis motors?

I have the 10W CR-Laser Falcon, which is 400mm*415mm and has one stepper on each axis.

No, I cannot distribute the firmware, as I do not own it. Please contact Creality support (cs@creality.com).


Thank you. I emailed them for the firmware.
Question- how did you wire the two Y-Axis stepper motors to your control board? I’d like to make sure that I have them wired the same as you while I wait for the response from Creality.
ThNk you!

Apologies for any confusion, I have the full Falcon 10W unit, not the kit to convert a 3D printer. Please be sure that the firmware provided is for the right model. They are named differently. One is “Ender-3 S1 CV-Laser Module Firmware” and the other is “CR-Laser Falcon User CV-30-Firmware_V3.0.24”. I have the latter.

That is the firmware they sent me. It was a kit originally to add to the 3D printer, but I installed it onto a 400x400 laser platform. It was a fox alien laser on a Riezer bed. Laser went bad and I installed my falcon laser and control board on it. Hoping this firmware works. It should. I’ll try this evening

Unless there are more changes to the firmware than what messed up homing I wouldn’t expect the firmware to change anything with stepper motion. In any case, worth trying.

The 30.0.20 firmware definitely changed the behavior of my laser. It homes consistently to 0.0 now, with no pull-off. It also appears to match the laser power to the requested speed more accurately, I’m guessing, because the cut lines are much cleaner, even with Air Assist off.

Frankly, it acts like a completely different laser, compared to the 3.0.24 firmware behaviors which were giving me heartburn.

I hope this to be the case. Mine moves but is very erratic and the stepper motors for the y axis don’t seem to be totally in sync. one seems to be a bit lagging. i may need to get motors that are for a 24v system, since creality stuff is 24v. maybe that doesn’t matter? let me know if you think it might.
It sgoyld all be very simple. im using a creality 10w laser with the creality falcon control board, on a generic 400x400mm platform with generic stepper motors. someone please lwt me know if im missing something.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.