15w laser settings for gbrl

grbl

(Michelle) #1

Hi There

I recently replaced my 2.5w laser with a 15w laser. I have connected it to my controller board.

it works well moves x and y my only problem is my laser is not firing at all?

Also the job doesn’t start at 0% it starts at 40 or 50%

I also get a homing error5

please can you assist me before I buy the software.

I’m from South Africa.

Thank You

Michelle


(Rick James) #2

We want to help, but you will need to provide some additional information as part of the process. What version of grbl is installed on your controller? What are your current settings in your grbl firmware? Type $$ followed by the ‘Enter’ key in the LightBurn console and post the entire contents here (note: the console window is scrollable allowing you to copy entire contents). Let’s start with this and go from there.


(Michelle) #3

Hi Thank You for the respond and assistance im very new to this. Here is the current settings
$0=10

$1=25

$2=0

$3=6

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$100=40.000

$101=40.000

$102=400.000

$110=8000.000

$111=8000.000

$112=1000.000

$120=500.000

$121=500.000

$122=200.000

$130=200.000

$131=200.000

$132=200.000

ok


(Michelle) #4

This is the complete message on the screen

Grbl 1.1f [’$’ for help]

Homing

ok

error:5

$$

$0=10

$1=25

$2=0

$3=6

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$100=40.000

$101=40.000

$102=400.000

$110=8000.000

$111=8000.000

$112=1000.000

$120=500.000

$121=500.000

$122=200.000

$130=200.000

$131=200.000

$132=200.000

ok


(Oz) #5

“Error 5” means you have not installed limit switches on your machine, or enabled the GRBL homing command, but you’ve told LightBurn to home the machine when you connect (the default). You will need to turn that off.

When you say “the job doesn’t start at 0%”, I assume you mean the progress bar in the software? If you’re sending a circle or simple shapes, that’s expected. GRBL buffers a bunch of commands before it starts to cut, so LightBurn sees half of the job go out before it has to wait for the controller to catch up. If your jobs are larger, this will be more accurate.


(system) closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.