2D dxf imported objects are huge

So I have been importing 2D drawings created in Autocad / Turbocad in MM into RD Works for about five years now. I just downloaded lightburn to give it a try and the same files when imported into lightburn are huge. I have lightburn setup in MM and the dxf files are also in MM. RDWorks has no issues.

How do I fix this?

In LightBurn, click the ‘Gears’ icon near the top-center to expose the ‘Settings’ window. Click the ‘File Settings’ and show us what you have set there.

Here are three images.

  1. Area of the dxf import paraneters.
  2. File imported in RDWorks Size is correct
  3. File imported in LightburnDXF Import setting In RDWorks Screen Shot One

Try ticking the ‘Auto-detect units if possible’ to the Off (red) position. Now reload the file and let us know how that goes.

DXF files don’t always have a unit of measure stored with them, and not all DXFs export their settings properly.

It does the same thing pieces are huge. I don’t buy that the dxf I am using does not have the proper information since the same dxf file has been used without any issues in

  1. RD works
  2. Autocad
  3. Turbocad
  4. Sketchup
  5. Gerber cutting system
  6. Teseo leather cutting system
  7. Haas

It was not my intent to imply anything about your specific file. :slight_smile: This was more of a general observation from the files we’ve seen submitted.

If you are willing, send this DXF file to support at lightburnsoftware dot com, and please include a link to this post for context, and I can ask the dev team to take a look.

Morning Rick,

No software is perfect. I am a CAD user since 1992 and have seen glitches in the most advanced systems. What I see is the attention to detail here which is more important than the problem.

Will go over to the office shortly and email the files.

Thanks for your help and proactive response

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.