50w blue and Gray is still dead...trouble shooting continues

Hello everyone. I stupidly and accidentally plugged my 50w blue and Gray laser into an outlet with reversed polarity and burned something up after about 60 seconds after turning it on.

I have replaced the switch power supply and the ruida controller/lcd screen but still not fixed.


  1. LED on new power supply still doesn’t light
  2. LED on laser power supply doesn’t light
  3. Ruida LCD doesn’t turn on or BEEP
  4. Air pump works with switch
  5. Water pump worked after initial issue but no longer works with switch (not necessarily worried about this one)
  6. I have tested the E stop, water flow switch, all fuses I can find, checked for ground, and ensured I am now using a properly wired outlet

What am I missing? I’m scratching my head

The quick check that stand out to me in this situation are:
If you have mains power to the inlet of your machine, do you get it also on the connections at the back of this. I believe there is a fuse built into that just under where it plugs in.

Do you have main power on the connectors from where the power comes in?
If yes, does that mains power get as far as the e-stop?
If yes, is your key switch turned off?
If no, do you get mains power to your power supplies?

For the LPSU the mains power passes through the Laser switch on its way. If this is OK, is the mains power reaching the LPSU

If the mains power is reaching the machines PSU are you getting the 24V output that supplies your controller?

Just a starting point.


How could this possibly happen?

Maybe if you clarified what you did and what happened in more detail.

As far as I know the world runs on AC…?


Depending on the power supply did you select the correct input voltage for your area?

Update: I have replaced the laser PSU, the controller PSU, and the ruida LCD and controller and some progress was made but still not fixed

I have noticed that when the ruida is plugged into the X and Y axis control modules that the led status light in the controller PSU does not light up. My thought is there is a short or something inside the x and y axis modules.

Searching the net and I can’t find anyone that has had issues with their x and y axis modules and I also can’t seem to source them for replacement. Any thoughts?

So with the stepper drivers unplugged all is good?

1 Like

Thats correct. I’ve got power to everything now except the ruida controller or the LCD screen when the steppers are connected

You just google laser stepper motor drives. Should be 2 phase drives…I think dc input but you have to .
Probably a bunch on eBay and amazon find out what type of nema stepper it is nema 19 etc…should say on the motor. They’re easily available

1 Like

I’d disconnect them one at a time at the driver to see if it’s just one or both. Then I’d disconnect just the stepper motor to see if its the driver or motor.

1 Like

When I connect either one if these is when the controller PSU stops responding

your stepper drive on eaby
In case you need a new one…this is the same model…like I said…fleebay

1 Like

I had already ordered 2 of these from Amazon but I’m looking closer now and it might not be the same as the one you listed

Actually it should be fine as it is nema 23 rated as is the 545A with 128 steps so I think your fine.

1 Like

Do you have different stepper motors for each axis?

They are configured differently.

It helps in diagnostics, to understand what happened to begin with.

The main issue with the two pictured connections is that power and ground for the steppers are there.

Might double check those.


1 Like

Yes there are two steppers and it does not matter if I plug in one or both, as soon as they are connected I no longer have power at the controller PSU.

Many persons here have suggested things to check, but you reply about something else and ignore their requests.

We are trying to help you, but it requires you to interact. You start the thread

How, in an AC world, could you plug it in reversed?

This is an important issue in fixing equipment. It gives many of us an idea of where the damage can be.

The next response from you is you changed out all the electronics. ? why?

Now we have no idea of what you have done, or the current state of the machine or even if the wiring is correct.

“They are configured differently.” doesn’t seem to bother you. Yet these motor drivers have been your problem focus for your last few posts.

Did you save the configuration from the original Ruida and restore it to the new Ruida?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.