6445G and omtech chuck rotary

I’m trying to set up my chuck rotary. If I use the rotary set up menu in lightburn and change my steps per rotation. Nothing changes, stock 10000 steps 80mm chuck it rotates 3.5 times. 1 step per rotation and it rotates 3.5 times. I’ll switch rotary on and reread settings and it turns back off. I’ll set the circle pulse on the controller to 250. Then reread in lightburn and it rewrites to 10000. I feel like the controller and lightburn is fighting each other. Any idea on how to get this thing going?

I have a piburn, so not a chuck type.

My motor driver is set to 2000 steps for a rotation.

Where did you get the numbers you are using.

I have never had it ‘not’ write to the controller without some kind of error message from lightburn.
Are you USB or Ethernet wired?


I am using it over WiFi. Im not really sure why it wouldn’t accept my settings. I started with the stock numbers in the rotary set up menu. Noticed that no matter the numbers I did use. Nothing changed. What I think it comes down to is the 6445 is built for the rotary to be on the U axis. You do have to go into the controller on the machine and enable rotary and set diameter on the controller. I then switched my y axis plug to the u axis port and everything worked as it should. I’ll mess with it more and will try to update this post with my findings. There seems to be some confusion with using a rotary on a 6445 controller and I think it points to the u axis.

I have a 6442 and I think the only difference is the display resolution.

I have a rotary and have always run it off the Y axis. You are lucky to have a U axis available, I only have my X and Y motor controllers. I am planning to move mine to the U axis. Have all the parts, just have another laser project going.

There is a configuration difference in them. It doesn’t know what you have hanging off it… It could be squirting out window dressing for all it knows.

Just relax and work with it, you’ll get a handle on what it’s up to…

Hang in there and keep us up to date… :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.