9.0.7 crash problem with LARGE PHOTOS

Hello, my frend have 80W laser from china,i think, with Ruida controller 6442G, and i have Eleksmaker A3, same problem with BIG LARGE photos over 589mm or so…
Problem is Lightburn get crashed after send code to machine,

and nothing can we do…

After setting photo to 580x401mm its all ok

Frend have laptop pc with Intel atom 1.6Ghz 4gb ram and i have Intel i5 3.5Ghz 16gb ram and same problem with crashing Lightburn, any ideas or just wait for update? THX

I have not seen this reported before, but LightBurn should not crash. Do you get a crash report or error message? Please post any report you receive. I am not seeing the same from my side so any further details that could help us reproduce this issue would be great.

Are you and your friend sharing the same file or are you producing different files using the same image? Please post the offending LightBurn file and the image file as well so we can tale a look.

What DPI are you using?

Chances are very good that your laser controller will not accept an image that large, though it will depend on the image, and the dithering mode. Ruida has a maximum job size of about 100mb. For the Eleksmaker, the size shouldn’t be an issue, but memory might be if your DPI is set too high.

Also, are you using the 32 bit, or 64 bit version? The 64 bit version has access to considerably more RAM.

Hello,


This is picture what Friend use, settings was speed 175mm/s power 20% 0.02mm/line 589x389mm, picture was sett to middle. We both have 64bit version.
Iwe dont become report/ where can i look?

0.02mm per line is 1270 DPI. There are probably lasers on the planet capable of this, but none you or I could afford. That’s 1.6 million pixels per square inch.

389mm / 0.02mm per line is 19,450 lines
589mm / 0.02mm per dot is 29,450 dots

So, 572,802,500 dots, with each dot requiring a start and end point, power value, and some other bits. You’re running out of user accessible single-block memory. Your controller wouldn’t hold it anyway - Ruida has a 100mb job size limit.

Lowering the DPI to 500 (0.05mm) would cut the job size by roughly 6.5x, and is close to the highest DPI possible with typical consumer grade lasers.

With this setting, your image as an RD file to be sent to the laser is 103mb, so you’ll need to lower it a little still, or use a more compact dither mode. Newsprint optimizes for size by using larger dot clusters and is what I’d suggest if you’re going to stick with a high DPI like this. Using Newsprint cuts the RD file size to 46mb.

Oh, my bad, sorry, resolution was 0.2mm per line. So we need lower DPI / bigger resolution ? Image setting was Jarvis. And we dont use RD file, just sent to machine via START button

With 0.2mm per line, it should be no problem for the 64 bit version. Is the photo you posted the full resolution image? I was able to generate a 589mm x 389mm version of that using 0.05mm interval with no trouble in the 64 bit version of LightBurn. Using 0.2mm would require much less memory than that, so make sure that you used 0.2mm not 0.02mm.

You use an RD file no matter what, you just don’t see it. The software generates it in memory and sends it to the controller as a temporary file.