Absolute coordinates issue

What i see on the screen does not match what my machine is trying to do. I have the origin set to the lower left corner and I home the machine in the upper left corner. The laser head moves in the proper direction when jogged and display coordinates appear to match the lasers position. However whenever I place an item in the middle of the design area and set start from to absolute coordinates it does not move to the correct spot. It ends up hitting limit switches instead. Here are my GRBL settings for reference


1 Like

Two settings you might need to change:

  • $10=0 (this changes the position reporting to be in work coords, not machine coords)
  • $32=1 (this enables laser mode, but won’t fix the coordinate issue)

Your profile says you have an Eleksmaker - Does it have limit switches, and homing enabled? If so, when the machine is homed, what does “Get Position” report? (it’s a button on the Move window)

1 Like

Yes. I have homing switches installed. When homed the position report says. X=-368 Y=-2. I have changed both settings that were suggested and no change

Type this in the console and press enter, then copy / paste the output here to the forum:


The first entry, G54, should be all zeros. If it’s not, type G10 L2 P1 X0 Y0 in the console and press enter. That will clear the offset. It’s also possible that your machine is running in negative coordinates (not uncommon for CNC machines, fairly uncommon for lasers). If that’s the case, read here for how to add a workspace offset to correct that: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md

Here is the results of $#












My usable bed size is 370x320 so i made an offset workspace using the command G10 L2 P1 X-370 Y-320 and restarted the software. Absolute coordinates is now working like I would expect. Thanks