After installing lightbridge, left is right, right is left

All, i tried. I really did! I flashed my raspberry pi and installed everything i needed. I found my pi and connected the lightbridge. It works, but it is going left when i select a location in the right half and the reverse on the other side. I have an ontech 100w co2 with a ruida controller. Im almost there, what could it be now?
For a heads up, i made sure console tab was shown in my right hand screen, but when i open it, nothing comes up. Its all grayed out and i cant click anything. As for the normal moves that happen in my grbl within console, this is blank in the ruida lightburn



Im on windows 11

Is this a brand new laser installation or did you previously have it configured with USB or ethernet?

First obvious thing is that your Origin setting in Edit->Device Settings is incorrect. Looks like you have it set to Top-Right. Is this where your laser head homes to? If not, change origin to same location as to where the head homes.

Do the jog controllers on the controller work in the right direction?

Yes, home is top right. Controller works as normal. Left‐left, right-right, etc

How exactly are you moving the laser head? Are you using the laser map pin tool in the toolbar? That’s what it seems like from your description.

Do the jog controls work correctly in Move window?

Yes, map pin tool. This a worked before i hooked this up via light bridge. Jog works as normal. Maybe the controller i selected is the wrong one. Though it was the only controller that showed up

As you say, you probably don’t have a choice in this.

It’s odd that this worked before switching to Bridge. The Bridge should not have introduced anything like this. Is it possible that something else has changed?

Can you confirm that the machine homes properly? What are the coordinates after homing?

Assuming this is the Ruida…

If he created a new device profile for the bridge…and didn’t pick the right ‘origin’… ?

This isn’t a bridge issue…

:smile_cat:

I selected top right as my origin. When it homes, it goes top right and the coords say x:0.0mm y:0.0mm

Its the setup within the settings for lightburn bridge. I set the test image in lightburn (included picture) and couldnt move the laser from lightburn. Remembered that it defaulted to my ruida pre-bridge settings. I switched to the bridged ruida and it flips the image in lightburn backwards

Sigh… close this one out too. I went into device settings and changed origin, which i thought i did that already. Doing so, flipped the image. Everything is working correctly. Im gonna set this device setting as default and remove the extra ruida to minimize my confusion

1 Like

You were right again Jack

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.