After latest update I hit start and lightburn just freezes

I have been using lightburn for 5 months on my Thunder Nova 35 with no issues hitting start from the program and boom laser starts cutting. Now I hit start and nothing happens beside the laser engaging but not doing anything elser. I can see the timer going. I have to hit stop, esc and the force close lightburn. This is super unproductive since I do a lot of one off work and have to change designs constantly. I downgraded, uninstalled, still same issues.

Your profile states you have an xTool? … this comment is for a Ruida…


Might try to send it and start it from the console. This would tend to indicate an issue with the communications, not the generated Ruida code.

It might be a helpful step to determine the issue.

The machines out in the garage, so I don’t use start.

If you don’t mind posting the offending .lbrn2 file, I’ll try it on mine.

Which version exactly are you running?

:smile_cat:

Jack, didn’t realize that was in my profile but I run a Thunder now. This is all files so its not that, sending to the laser works fine but its time consuming. 1.4.03 the current version is what I am running now. The version before I attempted and still the same issue which was not the case before I updated the first time.

Are you sure you’re configured for the Thunder and not the xTool?

There is no timer on a dps controller, as Lightburn sends the whole file…

Double check the device and ensure it’s the right machine.


Anyone who has ever scoured the Internet for help with a technical issue eventually finds a post where they are using the current version. Which means nothing to the person trying to fix the problem… especially if it was posted months or years ago…

Current is relative statement and down the road it’s pretty useless to anyone looking for help. Take the minute to include it… it’s always nice.

:smile_cat:

Mine is doing the same - Sits on Optimizing Cut Plan and will not go any further

100% on the right machine. Have been running it for 4 months on the same computer with 0 issues. Everything works fine except I Iost the ability to run the laser directly from lightburn. When I hit start the light goes red, fans starts but no movement on the head. On the controller I can see the job timer is moving and light burn just freezes. I have to force quite and restart lightburn.

1 Like

Re-Installed the previous version and it works fine

Can you outline the steps and which version does what. It will help find a bug…

@JohnJohn can assist… I hope.

:smile_cat:

Newest version gets stick on Optimizing Cut Plan - The laser fan starts and everything but it never moves - I have to Force Quit to get out of LightBurn

Previous version works perfect

1 Like

One of the seemingly Unrelated things to check before we collect files and begin testing is the amount of remaining memory in the controller.

DSP controllers tend to hang on to previous files sent by LightBurn and the controller will behave in unpredicted ways after a couple of months if the memory is nearly full.

Please let us know if the controller is mostly full and delete surplus files (in the controller) that aren’t urgently needed.

Please Confirm and retest. :slight_smile:

So the issue starts with 1.4.02 and carries into 1.4.03. I just went and installed 1.4.01 and I have no issue. I must have never installed 1.4.02 so makes sense when I dropped to the previous version the issue was still present. That solves my current dilemma but still means there is a bug in the latest version and I cannot use it at this time.

1.4.01 fixed my issue, seems like you might be on the right track.

1 Like

Did you retest with the identical file or a smaller file when you rolled back to the previous version.

I just need to make sure the Devs aren’t chasing ghosts / artifacts.

Please attach the lbrn2 project file where you’re seeing this, and the lbprefs files for Version 1.3.01 and Version 1.3.03

The lbprefs file can be exported by clicking File, then Export Prefs, then saving that file somewhere convenient so it can be shared or sent easily. You’re welcome to share them publicly or send them to me directly here. I’ll get the files into testing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.