After update Lightburn 1.6 device will not connect to Mac

I am a newbie to my K40 and Lightburn, so forgive me if this is a me problem. But yesterday, I upgraded to Ligtburn 1.6, and now it won’t find my device. I entered it manually, but then in the console, said, “waiting for connection.” I tried a brand-new USB cord, but that didn’t help. I have an Omtech K40+ and a 2024 Macbook Pro M1 Pro chip Sonoma 14.4.1. Right now I am dead in the water. Any suggestions would be appreciated.

Hello Jennifer

Question please.

  • What was your previous version of LightBurn
  • In the dropdown menu in front of Devices (on the laser panel) what devices are listed?

I was using an older computer and it was 1.5.6??? But that one stopped connecting also when I did the upgrade. So I moved to the new computer and got the same thing.

Nothing is listed in the devices, except the one I added manually, and with that one in the console is keeps saying waiting for connection.

Try this for me

Power on your machine - close Lightburn
Open a terminal

in there type
ioreg -p IOUSB

Post the output please?

Also are you using any USBc/USBA hub in between, if not, could you add one if you have one available?

Last login: Tue May 7 08:10:38 on console
jenniferlander@Jennifers-MBP-2 ~ % ioreg -p IOUSB
±o Root <class IORegistryEntry, id 0x100000100, retain 37>
±o AppleT8122USBXHCI@00000000 <class AppleT8122USBXHCI, id 0x1000004b8, reg$
±o AppleT8122USBXHCI@01000000 <class AppleT8122USBXHCI, id 0x10000056a, reg$
±o AppleT8122USBXHCI@02000000 <class AppleT8122USBXHCI, id 0x100000400, reg$
jenniferlander@Jennifers-MBP-2 ~ %

I am using a USB A to USB C - that is the only thing my Mac will really take unless I use an adapter.

Same problem here and I have a deadline to meet.

Could you try that please?

Sorry for the delay somehow i did not get the notification.
Note though - your laser is not being detected at all.

Do you happen to have any other computer/laptop windows maybe you could use just for sanity check?

Yes, I can use my husband’s old (2017) mac and that works. But my new one does not. We have realized I do not have the correct cu.XXXXXX After devices, I have a debug and a Bluetooth incoming port, but nothing that looks like what is on his computer.

This is getting quite a common problem
Newer Macs - especially the Apple Silicon ones M1/M2/m3 and so one - are quite picky on how they connect to the external USB devices.

The Mac trys to force a USB3.1 handshake - but fails and will not attempt any lower protocol.

A common solution is to amazon in the cheapest USBC 2.0 Hub you can find. The cheaper the better in this case.

Something like: https://www.amazon.com/Syntech-Adapter-Thunderbolt-Compatible-Chromebook/dp/B08THLZ4K9

So I was in lightburn yesterday and was able to use it no problem, and no connecting issues. Today I go in to do some work for some engravings and it doesn’t connect. Looked up how to reconnect to it and was able to connect and use it again but the only problem is when I open up the file I was using and tried framing it, the laser acted like it took up the whole Y grid and started messing up on me. When I framed a square on a new file there was no issue? Anyone know why that is?

Thanks. Just added it to my shopping cart.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.