Air aissist Problem

Hi! I have added a 24V solenoid valve for air assist, in RDWork When the work or layer with air assist on finish,the solenoid valve turn the pin WIND in 0V, in lightburn the pin remains high 24V and the solenoid valve doesent turn off what is the problem?

Do you have the solenoid valve connected to the +24v pin (6) and the wind pin (5)?

Yes, +24V pin 6 but on the second strip and Wind 0V pin 5 first strip

I will have to look to see if RDWorks turns it back off again somehow. I have not noticed such a thing with my own hardware.

1 Like

OK… watching this one closely.

I installed the air kit a couple of months ago and it doesn’t work because the WIND pin is always low and the solenoid always on.
I didn’t have time to do much trouble shooting at the time and it’s fallen kind of low on my “to do” list. I have no idea if it works with RDworks… my Linux box don’t run it.

Curious to see someone else having trouble with it.

The WIND pin is a voltage ground, or is left unconnected. It will always be low - you tie a 24v source to one side of the solenoid and the other side to the WIND pin, that should work. How did you wire it?


i added an air solenoid a year ago and it has worked correctly with every version of lightburn. never failed.

ruida controller,

Yeah, mine’s wired between +24 & WIND.
I expect to see WIND pulled low (towards 0V) when air is turned on, and float back up to 24V (pulled up by the solenoid coil connected to 24V) when air is turned off.

On mine WIND is always low, always putting 24V across the solenoid.
There’s a place in “Machine Settings”-> “Vendor Settings” called “Enable air-assist output” and I’ve got it checked for “True” but it still doesn’t work regardless of set for true or false.

I’ve never suspected it was a LB problem and still don’t. I’m starting to think something funny is up with my controller.

Yes the solenoid is correctly wired, and in RDworks work perfect, in lightburn it turn in when i want but didnt turn off when it finish

For a test, can you create a layer with air assist on, and a 2nd layer with air assist off, and run in layer-priority? Does the 2nd layer turn off the air assist? If so, what happens if you delete the 2nd layer?

I have already done this test and nothing, LB do second layer with air on and keep it on

Any other idea?

@Simonefailla - Are you running directly from LB or sending to the Ruida and then starting the job from there? I just got a brand new machine with a Ruida and I noticed that there was a weird issue with air assist when running direct from LB - different issue (doesn’t turn on when run from LB but does when run from Ruida) but I wonder if there was some recent Ruida firmware change that mucked with air assist a little. If you are running direct from LB, try sending to the Ruida and starting from there.

1 Like

I have a related problem. I have a new laser cutter with a Ruida 6442G controller. The WIND output doesn’t change state regardless of whether I use LightBurn or RDWorksV8. The output is floating (no connection to either +24V or GND). One of the general purpose outputs (Out1) does change state, so I know I’m measuring it right, but its phase is backwards, and I don’t think it changes state with the laser. Is there anything I need to do in the controller setup to enable this?
I’ve looked at the manual, but if it’s there, I missed it.

For wind to work you need to enable IF Blowing. You can find it under:
Manufacturer parameters -> Machine config -> If blowing
(set to yes)

Did you do this?

In Lightburn, I have the air assist switch turned on, and in RDWorks, IfBlowing is Yes. (I’ve tried making rd files with both softwares)

I don’t see the menu that you refer to, though. Are you talking about RDWorks or LightBurn?


I am talking bout the setting in the Ruida controller. I am not sure if setting this in RDWorks will set this value. I configured my controller via Ruida display and then tweaked via RDWorks.

Just checking if your controller actually has this setting set to yes

Thanks. I’m having trouble finding the menu you describe. I haven’t been able to get into any configurations from the Ruida display. All I can find is Set Factory Param and Set Default Param. When I use the passwords “CC8888” or “HF8888” I have password success, but can’t go anywhere from there. Am i missing something? Sorry to be so ignorant. The manual is pretty sparse on information. Also, when I connect my computer via USB, the Windows Device Manager recognizes the controller present, but neither RDWorks nor LightBurn can find it. I’m feeling pretty dumb.

I see that I have read your Ruida controller type number wrong. You have a 6442G and I have a 6445G. Small difference hehe. Sorry.

I had a look and found the following manual:

That manual states the following:

Enable the blower: if use Wind signal of output port to control the blower switch as layers, you must
enable this item, otherwise, the Wind signal outputs other signal.

It should be under (4) Enable Parameters.

Did you input this on the controller screen or RDWorks? When I go into rdworks and enter the password under vendor settings I get into the vendor menu. Again, 6445G controller.


In Lightburn I just have the following:

Back to measuring stuff. How do you measure this output? You should measure between the +24V output pin and the Wind output. If the controller is in standby, you should measure 0V, If you start your program and the wind output is set by the controller, you should measure 24 volts.

Under Edit menu, Machine settings, Vendor settings, exist an “air-assit Output” option. DOn’t know if it works cause i don’t have the selenoide valve installed yet