ALARM 2 ERROR 9 in Calibrating Camera Alignment Ortur Laser Master 2 PRO

I bought a Ortur Laser Master 2 PRO last month and tried a few jobs with LaserGRBL, everything seems fine. Then I installed Lightburn Trial on Mac and Win computers.

I connected an old iphone SE as Webcam with the app (Epoccam) to a PC and went through the “Calibrate Camera Len” smoothly with all values under 0.1.

Then I continue to “Calibrate Camera Alignment”, I pressed the “Frame” button, alarm and errors come out. I googled and tried some settings people suggested but no help. I am stuck here now.

I would be grateful if anyone could help, thanks.

Waiting for connection…
Waiting for connection…
[ORIGIN: China]
[MODEL: Ortur Laser Master 2 Pro]
[OLF: 152]
[DATE:22:08:08 - May 16 2021]
Target buffer size found
Starting stream
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 3:
Stream completed in 0:00
[MSG:Reset to continue]
Ortur Laser Master 2 Pro Ready!
OLF 152.
[MSG: Flame detector active,Ambient infrared value:4069]
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
G-code locked out during alarm or jog state.

How is ‘Edit → Device Settings’ origin set?

It appears to gag on line three of your gcode. My guess is you are driving it out of bounds. You could post the first 5 or 6 lines of your gcode. You may wish to check out the docs on the coordinate system.

Error 9 is a failure to home. Lack of limit switches or a wiring failure.

Did you go thought the lightburn setup for grbl?

These are usually configuration issues.

Thanks for the prompt reply, Ortur has suggested me to use $RST=* to restore machine default setting, the calibration alignment can be done.

However the calibration marks and overlay image result are quite blurry. I tried to etch a few polygons in different areas. They are inaccurate, even I offset a bit. I would like to know is it due to low resolution (640×480 Free Epoccam app), camera angle or other reasons?

I am considering to buy an usb camera module or webcam, which is suitable – 5/8MP and W/N FOV for 40x40cm OLM2 PRO?

Thank you.

it looks like your camera is too far from your machine and because of that the image must be zoomed in to that degrades the quality of the image further. Try mounting your camera so the inside of the work area fills the camera screen.

There is documentation on setting up the camera from Lightburn.

Here is a camera setup video from them.

I believe they suggest a 8mb camera, 5mb minimum.

Part of the setup gives you the focal length lens of the camera you need.


Don’t enter a value for material thickness - your laser does not have Z control, so that won’t likely work, and might be why you’re getting the ALARM:2 errors.

Regarding the image, a 640x480 camera is not going to give you very good results - you’ll have, at best, about 1 pixel per millimeter of working area, and ideally you want about 3 to 4 times that, horizontally and vertically.