Alarm 2 g-code mation target exceeds machine travel

i have the monport k40. im get the alarm2 $130=300.000 $131=200.000 in device setting it matches 300 and 200 i have reinstalld lightburn and i get the same problem i have right click device button same problem. 2 days ago i was getting alarm 9 i was asked to check my $23 because it wouldnt home to the rear left. we change it to $23=5 and that solved that problem… so i put a box in my work space and hit frame. and i started getting the alarm 2. please can someone help me with this . machine is 3 mo. old bought with lightburn

Can you confirm if jogging controls work in the intended direction? Left moves left, right moves right, up moves up, and down moves down?

Please run these commands in Console and return all output:

$H
$$
$#
?

ok in the move box left and right is ok. up it moves laser down. down is up. you still want me to run the $

Yes.

Also, take a screenshot of Edit->Device Settings please.






Your machine’s behavior doesn’t seem to match expected default. Not sure why that would be.

But try this. Run this in Console:

$3=6

That should resolve jogging direction. However, this might negate the homing direction fix that you put in earlier.

If homing fails then revert the homing direction to default:

$23=7

After all is working home the laser and run these tests:

  1. Check jogging direction
  2. Using “Get Position” in Move window check that post-home location is 0,0
  3. Check that position increments as you move to the right and down
  4. If all those pass, then run a frame test

If anything doesn’t work as expected report back with results please.

it did change the home $23=7 fixed the homing to the rear left. i framed a small box in 3 locates seams to be ok now

Great. Hope it goes well for you then.

thank you so must for your help and fast replys on this

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.