Alarm 2. Longer B1 40 W using Longer Rotary

I have the B1 40W running with Lighburn. I am trying to use my Rotary and keep getting the error message below. I have figured out it is triggering the alarm when I have my start from position set at either user origin or current position. Also, when I try to home and manually trigger the Y axis limit switch I get a homing error. I tried to go back to the normal setup and found that I also get the same Alarm 2 error message when I have the user origin or current position set. I should be able to use this option, but for some reason it isn’t working. I’m not sure what else to do. I have reached out to Longer as well as posting here. ALARM:2
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)
On or near line 0:
Stream completed in 0:00
ok
Grbl 1.1 [‘$’ for help]
FW:LGT V1.2.3|MB:LS_ESP32
ok
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
ok

Hi Molly,

Normally when using rotary you must disable homing.
The error when homing - alarm 9 - will lead to negative coordenates
You can check - after homing and fail
Go to MOVE > Get position
What does it say as X and Y

What Start From are you trying to use? Current position/Absolute coordinates?

Thanks for your response. I did disable homing. In an effort to clear the error I did try to do a home knowing I would need to manually trigger the Y limit switch, which did not work. I will try the Go to MOVE> Get Position in the morning.

I get an error when I try try using both Current Position or User Position. I cannot use either of these. I even returned my setup to the standard engraving setup without the rotary and the laser only works when I use Absolute.

1 Like