Alarm 2 when trying to FRAME

I’m trying to FRAME a project and I get this…
ok

Starting stream

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]

ok

Ortur Laser Master 3 Ready!

OLF:205_RC16.

OLH:OLM_ESP_PRO_V2.4.

OLM:GENERAL.

GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

[MSG:‘$H’|‘$X’ to unlock]

error:9

G-code locked out during alarm or jog state.
Any idea what I should do?

This means that the controller believes you’re asking the laser head to move to a location beyond the working area of the laser.

This is generally caused by a few things:

  1. You’ve manually moved the laser head by hand after homing
  2. The machine isn’t properly homed (either with homing switches or manually). In manually homed machines you need to start the laser with the laser head at origin position.
  3. You are working in “user origin” or “current position” and not properly accounting for position and design size. I recommend working exclusively in “Absolute Coords” for a machine that homes at startup until you’re very familiar with the functioning of the laser and how these various “Start from” modes work.

See if any of these apply to you. If not, can you provide as much description as to the situation that you’re in before framing? Also, a full screenshot of LightBurn would be helpful.

I am totally embarrassed! I had clicked on the “enable rotary” button. So thankful for your advice though.
Aloson

1 Like

No need to be hard on yourself. You’re not the first person to have done that, and I’m fairly certain you won’t be the last either.

Glad you figured it out!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.