Alarm 8, Limits are wired properly

Hey all,
Recently my Atomstack will not go home. This appears to have happened after grounding and bonding the unit (Not saying this was the cause, that’s just when I noticed it). The machine works perfectly in every other respect. If I do a job in the middle of the work area and use the bottom left corner of the work piece, it does just fine. If I go to the “move” screen, it moves just fine. It just wont go home. I tried messing with the $27 and when I make it a large number the laser moves toward home VERY SLOWLY for about an inch then stops and throws the Alarm 8. I checked the switches with a multimeter, they do work. It’s just that the laser doesn’t get tot them.
Any settings is should check or switches in Lightburn that should be set a different way?


I hope you saved a copy of the original configuration… you can do this from “Edit → Machine Settings”

It would help if you could copy/paste the output from your console when it powers on (boots).

If it failed homing I’d expect something like this

Waiting for connection...
Grbl 1.1f ['$' for help]
Target buffer size found
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
Grbl 1.1f ['$' for help]
[MSG:'$H'|'$X' to unlock]
[MSG:Caution: Unlocked]

An error 9 is a homing error, error 8 is indicating that the command you attempted to send is only valid while the machine is in an ‘idle state’.

“Grbl ‘$’ command cannot be used unless Grbl is IDLE”

Do you have your machine configured to home?

This is my grbl for homing. I also enable soft limits… You shouldn’t need to modify the ‘backoff’ distance ($27 value)…

Good luck


Hmm, Mine is definitely an Alarm 8. No Alarm 9 ever came up. I don’t know what it means “idle state”. It wasn’t doing anything, just sitting there. I’ll take a pic of whats going on when I get home. I figure it has to be something I’m missing because it always homed before. I mush have hit a control somewhere, just don’t know what.

$ commands are issued to the controller (usually via the console) when the machine is in an ‘idle state’ or waiting for a job to be run. When it’s running a job, they disallow console $ entries.

Copy/paste the output of the boot and whatever you do that is causing the error.

Makes me wonder if you changed other values in the controller as $27 has probably nothing to do with the home problem you are experiencing. What made you check that value?

Good luck


Somewhere on the forum someone mentioned pull-off, I don’t remember the specifics now. But I was able to enter a $ command. Then I hit home and the X and Y motors make a quick pulse then it throws the alarm. I’ll get some screen caps.

Just restore the configuration from before you changed it and it should be back to normal. lol

Software has bugs and hardware fails. When you have something that was working yesterday but isn’t today it’s more than likely a hardware issue. Anywhere between a lose/broken wire to a failed component. I.E. don’t fiddle with settings. They didn’t, wouldn’t change on their own.

If you must ‘fiddle’, back them up and ensure you know why you are changing something and not a shot in the dark.

You should have reversed the change you made that caused it… That would have been logical step.

I don’t know exactly what Lightburn sends, but I’m suspicious that when it homes it asks for other things using the $ command. The machine would be in an ‘error’ state when you (lightburn) issues a command returning the error 8. This is just speculation, but it would explain why you get the 8 error.

We really need the boot messages from the console. Might add the list of $ values that come up also. You can use the $$ command to have them printed out.

I suggest, when you modify these, you do it from within Lightburn ‘Machine settings’, not the console. It’s safer and is in your native language, not an obfuscated numeric form you have to remember or reference elsewhere.

Lightburn may have made a backup for you if you changed it from the Machine settings…

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.