Alarm hard limit - Y

Good day everyone,

I seem to be having an issue with lightburn and my Omtech K40. I have upgraded the board to use lightburn and I get an error Alarm hard limit - Y after every job completes. I can clear the error by hitting the home button but the laser will not recognize or act on any commands until I have hit that home button after a job completion.
Any ideas or suggestions for a fix?

Does the Y axes actually activate the limit switch?

Is there an option on the smoothie board to tell the machine where to move the head at job completion?


There is a limit switch at the top left which I feel like is activated on the x axis but not necessarily the y.
I have it set to return home (top left) upon completion in lightburn. Question is adjusting settings in lightburn the same as changing settings in the controller or is that done separately.
My experience up till now is primarily with 3d printers so the settings are similar but still a bit foreign to me.

The controller handles the basic machine controls. Maximum speed of each axes, how fast to accelerate and other ‘basic’ settings. Most of these are really a ‘speed limit’ that the controller won’t allow you to exceed. This protects your machine.

The speeds and laser power set by the user are part of the code that is sent to the controller…

Make sense?

The controller is complaining about a ‘hard Y limit’. There are two ways to detect that limit, one is by checking where you’re sending it via software. The other if for it to hit or activate a limit switch.

The software limit is usually stated “Soft Limit”, whereas the other is a “Hard Limit”. Some thing is probably triggering the Y axes limit error.

Looks like you are set to ‘absolute coordinates’ I’d suggest moving the ‘art’ to the center of your work area. You are on the edge here and it may overscan and trigger that limit.


Very informative. I have been centering the art and still get the alarm. That photo was me testing the burn quality at the lower end of the bed. I was having a mirror alignment issue as well. Fixed that.
So are there parameters that I can set that will limit the movement and keep the hard hit from occuring. Perhaps if I adjust the home position to not hit the limit switch?

There is something askew with your configuration. The hard/software does virtually all of this for you if it’s set up correctly. Maybe you should check that…

Properly configured, this won’t be an issue. It almost always boils down to this.


So it’s more than likely a config issue probably around around actual bed size and what the settings for the bed size are?
I have yet to figure out how in lightburn to set up the x and y in mm’s as opposed to inches. I would like to be able to set them at 300 and 200mm vs the fractional inches settings that are currently there. I am wondering if that would have any positive affect?

You can select mm or inches on the toolbar.

Use the machine settings to ‘read’ the current configuration (I think it does this). If you haven’t saved a copy then ‘save’ it as a factory backup.

You can modify the settings and ‘write’ it back to the controller.

The software (Lightburn) should be the same in the Device settings as the machine.


After discussing this with the lightburn support I set the finish position sightly outside of the home position and I am no longer getting the hard limit alarms.
I don’t know if it’s the perfect solution but it’s working so I’m a happy guy. Lol
Thank you for all of your guidance on this.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.