Alarm: Homing fail approach

I moved my laser and now I’m getting a homing fail approach alarm. I know the problem is the position X=-1199.99 and Y=-1199.99. How do I reset this to 0,0?

Alarm|MPos:-1199.994,-1199.994,0.000|Bf:15,511|FS:0,0

I have a foxalien reizer laser.

Here’s what I am getting when my laser connects and my settings.

error: Alarm lock

[VER:1.1f.SXDYNZ-V2.1:]

[OPT:VMHL,15,512]

Target buffer size found

ok

Homing

error: Setting disabled

<Alarm|WPos:-1199.994,-1199.994,0.000|FS:0,0>

ok

error: Setting disabled

$$

$0=5 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=2 (dir port invert mask:00000010)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=0 (status report mask:00000000)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=3 (homing dir invert mask:00000011)

$24=250.000 (homing feed, mm/min)

$25=2000.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=2.000 (homing pull-off, mm)

$30=1000 (spindle max rpm)

$31=0 (spindle min rpm)

$32=1 (laser mode, bool)

$100=160.000 (x, step/mm)

$101=160.000 (y, step/mm)

$102=160.000 (z, step/mm)

$110=20000.000 (x max rate, mm/min)

$111=20000.000 (y max rate, mm/min)

$112=20000.000 (z max rate, mm/min)

$120=300.000 (x accel, mm/sec^2)

$121=300.000 (y accel, mm/sec^2)

$122=300.000 (z accel, mm/sec^2)

$130=800.000 (x max travel, mm)

$131=400.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

ok

Because homing is disabled in the machine configuration, the controller will not automagically home.

Set $22=1 and the situation may improve.

Then try the G10 thing. My apology for not spotting the Home Fail message.

It now moves when I click Home, but still slams into the stop trying to get to -1199,-1199. Now here are my settings and what I see when I click Go at Move to Position 50,50 in the Move menu.

$$

$0=5 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=2 (dir port invert mask:00000010)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=0 (status report mask:00000000)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=1 (homing cycle, bool)

$23=3 (homing dir invert mask:00000011)

$24=250.000 (homing feed, mm/min)

$25=2000.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=2.000 (homing pull-off, mm)

$30=1000 (spindle max rpm)

$31=0 (spindle min rpm)

$32=1 (laser mode, bool)

$100=160.000 (x, step/mm)

$101=160.000 (y, step/mm)

$102=160.000 (z, step/mm)

$110=20000.000 (x max rate, mm/min)

$111=20000.000 (y max rate, mm/min)

$112=20000.000 (z max rate, mm/min)

$120=300.000 (x accel, mm/sec^2)

$121=300.000 (y accel, mm/sec^2)

$122=300.000 (z accel, mm/sec^2)

$130=400.000 (x max travel, mm)

$131=400.000 (y max travel, mm)

$132=100.000 (z max travel, mm)

ok

Starting stream

error: Alarm lock

On or near line 0:

Stream completed in 0:00

error: Alarm lock

error: Alarm lock

error: Alarm lock

error: Alarm lock

The size of your FoxAlien is 400 x 400?
After you reset your work offset you could try thsi option:

Yes, it is 400 x 400. Here are my Device Settings.