Alarm when homing

I am running Lightburn connected to this board on multiple machines. All is going fine and now I want to install these limit switches.
After connecting the switches, setting $22=1 and sending $H, one of two things happens:

  1. No movement, machine switches to “busy” in Lighburn
  2. No movement, error <Alarm|WPos:2147483.648,-2147483.648,2147483.648|FS:0,-8|Pn:P|Ov:0,52,193>

GRBL settings:

I have tested the limit switches on another board (different brand) and they work just fine.

Any idea what might be wrong here?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.