Aligning the laser beam to coincide with existing graphics (sculpfun s9)

Hi everyone, I tried to solve this with a low tech approach: after setting lightburn to absolute coordinates I cut a wooden frame about 5X3 cm wide. I placed the outer side of the L frame tight to the x and y rods of the laser frame and after gluing the graphics to a precut rectangular wooden A4 3mm mdf sheet I placed it tight to the inner side of the L frame. Using the the first cutting attempt as areference I adjusted the graphics on the lightburn working area accordingly and got a better result. It took me a ton of trials and got nearer and nearer to the desired result - yet there were always a 1-2 mm ca. discrepancy from the drawn graphics. The worst part is that the results are inconsistent… So I cannot see how I can have the laser beam spot on where I want it to be time after time. I may be expecting too much from such a simple machine, but then may be someone has an idea for me?
Hope its clear… I could send a photo if not.
Thanks in advance
Yehuda

How tight a tolerance are you hoping to get between runs?

What are you doing between runs? Is this running jobs back to back? Are you ever moving the laser head between jobs? If you do, how are you moving the laser?

When running jobs back to back you should have nearly perfect repeatable burns. If you are rehoming between burns you will be at the mercy of the repeatability precision of your homing process.

Do you have homing switches on your laser?

What “Start from” mode are you using in Laser window?

Maybe this also helps here: Coordinate systems & workpiece alignment - Diode Laser Wiki

Personally, my Sculpfun lasers have always been consistent after homing and using absolute coordinates. But be aware: limit switches are a MUST if you want to use absolute coordinates and repetitive motions. The standard S9 doesn’t have limit switches. In that case, I highly recommend checking out LightBurns “current position” starting point and the framing function to align objects.

Hi, thanks for your reply. I don’t have limit switches (sic!) so I rely on absolute coordinates while being extra careful not to touch the laser frame/head while extracting and inserting the boards.
In my experience the perfectly repeatable burns you mentioned only apply when the burn is repeated without changing neither the board or the position of the drawing on the lightburn interface. But then, while shifting the drawing’s xy coordinates and repeating the burn on the same board without moving it and without touching the laser frame/head - the machine reacts inconsistently: if for example I change the position of the drawing relatively to the xy coordinates by 1 mm I don’t necessarily get the same shift in the actual cut, sometimes more, sometimes less. Next time I go to the workshop I will experiment this with a milimeteric sheet glued on the board, hoping it will help me to better understand what’s going on, I’ll let u know and post some snapshots.

If that’s the case then you most likely have a mechanical issue.

Even easier test:

  1. set to absolute coords
  2. make a simple shape
  3. burn the shape
  4. without moving anything rerun the job
  5. does the 2nd burn overlap exactly with the 1st? If not, there’s almost certainly a mechanical issue at play that’s preventing repeatability. There should be no reason you wouldn’t be able to get that level of precision from your laser.

I’ll try the current posion mode, thanks, I didn’t realize you can actuallty see it on the lightburn interface (the green dot, yeah, I got it!). But I don’t understand how the framing function can help me to align the cut wit the graphics, if I wish to get a precise result. So far I can only aproximately see where the burn is going to happen.

I did this test precisely, and it worked as you said, but then when I shifted by 1mm the drawing on the lightburn interface, the cut did not move consistently by 1mm.

I would suggest testing manual homing to see how repeatable you can get it. If you can register the laser module very gently against the front and left of the machine you may be able to get somewhat repeatable homing, for sure within a millimeter.

Was there any unaccounted movement in the laser module after the first run? It’s possible that if your laser is under tension or sitting at an angle the laser module may be shifting when the stepper motors power down at idle.

If you’re absolutely certain you’ve removed any mechanical issues from the system then you could experiment with setting GRBL $1=255 which will disable powering off of the steppers.

Very helpful, thanks. I’ll try what u suggested the next time I’ll be at the workshop.

One more question: can u please tell me where to go in order to open the GRBL setttings? which menu, etc.

2 ways to do this:

  1. Edit->Machine Settings
  2. Simply enter the command in Console

:pray: thanks, I’ll give it a try