ANNOYED seems to alot of glitches!

I have a co2 and galvo set up with lightburn and I am really annoyed my work has been saved up side down? when I go to the co2 the work is right way up… what the hell is the crap I have just spent a good amount of time on a project and now everything seems ruined grrrrr not to mention lightburn crashing , seems like these glitches need to be sorted!!

Do they both have the same origin for home?
If not, the program is going to load the file for the machine you set it up to run on.
Not exactly what I would call a glitch.
Select everything and flip vertical.

I have lightburn for co2 60watt and also 30 watt laser and I am VERY annoyed with ligthburn crashing and ruining my work!! I recently saved work and now it is presented upside down? if I switch lasers it will show right way up but I still cant recover my work so i am NOT best pleased !!!

it does not allow me to flip horizontal the text shows still shows incorrectly. If i save work it should be right way up its a simple as that. I am set up to run on all machines and even if I do happen to save on another machine I should be able to re save it on the correct machine, that said I do not remember saving this work on the incorrect laser set up

Sorry, vertical.

When I go from CO2 to galvo I need to flip vertically and horizontally. Sometimes the words don’t flip correctly so I select just them and flip.

Tbh I am not clear what you saying… If i select the right set up the right machine and then press open the file should load right way up. This is work I am doing on the fiber and as far as I remember it was saved using that light burn set up for fiber and I am select the fiber machine when opening

Thats a bug that needs sorting, who wants to mess about correcting light burn bugs every time opening a file? there could be tons of art work on 1 file am i sopposed to correct the text on all items everytime lightburn has a bad day ?

It has to do with the machine home settings. My CO2 home setting is upper right. The fiber laser is lower left. That’s why the project is flipped.

Please confirm you are following the correct procedure. :slight_smile:

Automatic flipping of loaded projects

Anyone with more than one laser knows that loading a file designed with a different origin causes designs to flip or mirror. This version of LightBurn will automatically flip loaded project files to the correct orientation, regardless of where the machine origin is. (Note: you have to choose the device first, then load the file)

Here I show exactly what the same LBRN file opened after changing the device selected.

GRBL Device

Ruida Device

Try changing which galvo is the x axis
That fixed same issue for me