Another "no enough space error" Problem

No doubt I am missing something in the settings but I am getting this error when I manually set up an engraving test matrix of four small squares. I have read the following thread and tried to correct as Oz suggests:


If my design is just one square, things run fine. When I add 1, 2, or 3 more squares in a row with centers lined up, I then start to get the error. The laser will cut the first shape and then cancel after giving the “no enough space error.” When I do the same pattern, resolution, bed location and engraving speed (300 mm sec) in RDWorks, it runs fine with no errors. I have tried many combinations and permutations of settings changes, “start from” positions, speeds (from 50 mm a sec on up) and bed locations without success in LB ver 0.9.11. I am probably missing something easy but am not seeing it and would appreciate any guidance. Here is the test file:
Four Engrave Squares for Wood Engraving Test.lbrn (9.6 KB)
Thanks!

Does it give the error when you try to frame the job?

… with the same ‘Start From’ settings? (Absolute coords / current position / etc) and the same job origin? If these aren’t the same then the comparison isn’t valid.

Does it give the error when you try to frame the job?

No, it does not.

with the same ‘Start From’ settings? (Absolute coords / current position / etc)

Yes.

and the same job origin?

I believe they are the same but I will have to recheck to be sure.

“Not enough extend space” will only trigger when the job actually runs, and the laser controller realizes that due to a combination of position, speed, and acceleration, the the overscan moves will go out of bounds. Move the job away from the sides of the bed, or slow it down.

Thanks for the replies. Yes, I saw what you said that in the other thread which is why I am stumped on this. I took the engraving speed down to 50 mm a second and had this super small pattern of four squares 5 mm in size in the middle of the bed plus tried all the different start from positions. That means there are 300+ mm on either side for overrun and acceleration/deceleration. Then it was complicated more by the fact it will run the first square just fine. You would think it could not even get to finish that first engraving item given this type of error. I hope to have a chance to do more testing in the next day or two.

Is there a possibility that you have a rogue node or line that’s outside of the bounds of your table, but is difficult to see?

You could do ctrl+a to select everything, and check it’s bounding box.

Here’s what it looks like with a rogue node and select all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.