Any possible way to switch the origin to start and match with the grid?

Hello everyone.

I have an Ortur Laser Master 20W laser.

I built an enclosure because I do craft/popup shows and make things live on the spot. Enclosure is full orange glass around for protection.

I used Lightburns “Swap X/Y” and it asked me to change the orientation of my laser. The Ortur LM3 homes to the bottom left but now it homes to the “top-left” as my laser is now vertical.

The issue is working while im in the enclosure, its hard to line things up with my waste board grid along with my honeycomb that has MM increments.

When I attempted to change the origin, it moves back into the quadrant that the laser homes in.

Here is a picture of what I’m trying to achieve.

Even thought the homing is now in the “top-left,” I’ve set my origin and return to at 0 for the X and 400 for the Y as that is my workspace.

Essentially, I want to have this as my 0,0 but like I stated, changing the origin just makes the laser work from the original home quadrant.

Any possible way to have the grid read this as 0,0 and not mirror the content?

Makes it very useful as I used a router to cut into 1 inch thick plywood and use this recess to change between my honeycomb and gridboard.

My honeycomb starts at 0,0 in the original bottom right or since the orientation change, the bottom left.

Not tested by me and I may have misunderstood you but try thsi option with default settings.

Hello. Yes I have tried this setting. It flips the axis. The issue is trying to get my “origin” set at the bottom left. When I run a job it’ll still start at the top left after the switch.

You have to set a workspace offset.

  1. Type $$ in Lightburn console window and copy/paste your GRBL settings to a text file for backup purposes.
  2. Check your laser axis movement by jogging with the arrows in Move window.
  3. Apply offset and confirm

.
Also read the Job Origin DOC.