AtomStack A5, Air Assist control, improper Homecycle

High, I am new in Lasercutting. My Machine is a ATOMSTACK A5 20W and i get just starting to work with it after some add-ons, mainly an enclosure with filtered exhaust to work with it in the living area.
Now I got two problems on getting my add-ons (Air Assist and Home Cycle) correct working.

Atom Stack Problem

System Information:

Hardware: AtomStack A5,

Controller: LaserBox V1.0 * ) Firmware: grbl 1.1f.20170801 OPT: VI, 15, 128

Software: LightBurn 09.20 PC: WIN7 64bit

Home Position: Lower left corner Workspace: X = 410mm, Y = 400mm

*) looks similar to Makerbase MKS DLC V2.0

I put the Hardware into an enclousure with filtered exhaust and dit add Home- and Limitswitches. Also addet an Air Assist System, supposed to be controlled by the Contollers Firmware .

The hardware and cables work all well.

But with the Firmware (imo) I have some trouble.

Problem 1:

I tried to control the Air Assist (5V signal needet) over the „Extra“ Connector (J25) on the controllerboard to turn it on only during scan or cut jobs. But does not work.

Signal is always on (+5V), no matter of setup in LightBurn to M7 or M8.

Sending M7 from the Console returns (unaffectet from setup) Error 20, unknown g-code.

Sending M8 from the Console returns no error, but nothing else happens to Extra Signal.

Question:

Which output-Pin / Connector is used for control of AirAssist? Turn on with M7? M8. Turn off ??

Problem 2:

Home cycle does not work correct. (Left lower corner supposed to be Home Position)

First of all: Normal movement via Console, Laserpositioning-icon, running g-code work well and correct as supposed within the coordinate System.

The Limitswitches also work correkt (enabled with $21=1), Also Home Cycle enabled, $22=1.

Machine default Setting $2=0, (X,Y,Z not invertet)

All switches trigger an alarm if manualy actuated during a move-cycle.

Therefore I assume the cables and connetions to the Steppers to be correct.

With default $23=0 (X,Y,Z not invertet) the machine homes to the upper right corner. (Funktion ok)

With $23=2 (Y invertet) the machine homes to the lower right corner. (Funktion ok.)

With $23=1 (X invertet) the machine does not home to the upper left corner as expected.

Only the X Axis is homing correct. Trips Limitswitch and moves back to release it.

The Y-Axis does not move. Y-Stepper not exited. No Errormessage. => (Funktion not ok.)

With $23=3 (X,Y inverted) for lower left corner same behavior as with $23=1. (Funktion not ok.)

Z Axis inverted or not inverted does not have any influence to the behavior above.

Conclusion:

If X is invertet ($23=1,3,5,7) the Y-Axis does not perform the homing-cycle. (Firmware-Bug!)

Question :

How can I get this fixed?

Hi,
Problem 2 solved.

Grbl default setting for HS pull off distance ($27=1.000) was to low to release the switch. Therefore the homingcycle failed. All homingpositions are now working so far. Not realy smooth yet.

I still have to do some aditional work on final adjusting f. e. on debauncing and filtering.

But a new Problem did pop up:

using Laser-grbl or LightBurn I can modify and write the Settings ($xx commands) to the controller and the modifications work as long as the controller stays connected to the Computer.

Once the Computer is disconnected or the Controller shut down, the modifikations are lost.

At the next power on the default parameters are loadet back again. That means that changing and writing the parameter to the Controller is not persistend. They stay only temporarly in the Controller.

Question:

Is there an easy way to store the modified Parameters permanent to the Controller?

Thank You.

AtomStack sent us one of their units, I just received it a few days ago and so far we have just assembled it, but not yet run it. I did already take it apart though :slight_smile: so I know that the board in there does look very similar to the DLC board.

It has $30 and $32 GRBL settings set correctly out of the box so it can be used with LightBurn immediately without any settings changes.

However, I tried changing some settings and noticed they did not persist across a power cycle of the machine. When I power it on, I notice an EEPROM error in Console along with the $$ settings list. Can you confirm if you see this EEPROM error in Console also?

It has the normal Atmega328p chipset - it should have EEPROM. Either they butchered it in firmware, or it’s a fell of the truck kind of chip.

I need to get some more hands on experience with the machine as is before I can flash a new GRBL build onto it and hopefully that fixes the EEPROM issue (if my theory that they butchered it in firmware is correct) and allows homing setup.

Also, please show me how you have connected the limit switches. Actually, if you can provide nice pics of all this, I can use them in the guide I am going to write and it will save me some time.

I don’t have answers for your other questions yet. Pics will help, I need to see what you’re doing.

Thanks!

Hi Ray

its the same behavior on mine.
Prompts Error #7, EEPROM read failed. Reset and restored default values.

To Your request for pictures: I made a lot of what I have done and tried to load some of them.
But it didnt work (due to space restrictions?).
I am not experienced at all to post on myself. Most time I read them only.
Also I do not know if it is ok to post it in this topic. Maybe another place or way is better.

Topic Home- & Limit Switch.

My Setup with the modified Limit Switches (removed Rollerlever) now works on default setting.

Also addet 4.7nF to the LS – Inputs on the Controller Board for noise suppression.

Homing can now be disabled and done on all 4 corners exactly as expected.

![|302x227](file:///C:/Users/jhs/AppData/Local/Temp/lu73081wujg1.tmp/lu73081wujpf_tmp_6f6cb9c21796acfe.jpg)

Picture showes (striped) LS mountet on the X-Axis.

But now aditional unexpected behavior of the SW poped up.

PWR on, Laser in the Front Left corner as recomendet by AtomStack (LS disabled by default) sets this Position to X=0, Y=0 perfect to just go ahead. All coordinates are in line. FL Corner is supposed to be the machine zero position. Position reading got from „Get Position“-Button in the „Move“ Screen

With LS & Homing enabled to FL-corner and running the Homecycle the

Position reads X=-409, Y=-399 instead of the expectet X=0, Y=0.

Therefore it seems to me that I cannot run a job with Homecycle enabled.

At the moment I am complete screwed up.

You should definitely post your pics in the topic here for easier viewing. However, if you already have a Dropbox or Google Drive with all the photos, I would not object to that in addition :slight_smile:

Homingcycle for Atomstack

The homing issue for AtomStack A5 is now solved for me. But it is imo only a workaround!

The AtomStack A5 does have nice rulers engraved on X- & Y-Axis, Position 0-0 on Left Front Corner. Fits well to Lightburn Workspace. Works (w/o homeswitch!!) well right out of the box.

With Limitswitch and Homecycle enabled ($21=1, $22=1) the machine homes (for all Corners set via $23=xx) by grbl default to 0-0 in the right upper corner with negative Workspace-coordinate set. (default for CNC Router)

Therefore there must be applied an offset with G10 L2 P1 Xxx Yyy together with $10=0 to report relative to Workspace origin. Then everything works well as expected.

But the AtomStack does not save (store to EEPROM!) the modified machine parameters (blocked by Vendor?!) so they got lost if the machine is turned off. That means, the parameters have to be remodified every time again after a reset or power on! Thats stupid.

@ray

It would be nice if You can find out if the chip is ok and could be flashed with new grbl firmware to solve that problem.

To upload pic‘s I could not realy manage now. If You are still interestet I can send it per email to You. (airdancer101@aol.com).

Anyhow I am looking forward to post the complete work soon on Comunity Laser Talk, because that seems me to be the right place for it. Still some work on it left for me to write the text and get the picture upload accomplished.

The easiest way is for you to create a Google Drive or Dropbox account and put the pictures in a folder there and share it. You can also upload them to an Imgur Album. And then post the link here.

Hi,
I also get the same EEPROM error.
It seems possible to flash. See
https://fr.banggood.com/mypage-index-Qc+GvH3a48FZrSM0hKB78g.html
It says

  • Flashed Arduino Optiboot.
  • Flashed GRBL 1.1h.
  • Added 12V power switch.
  • Added limit switches (for the homing to work you also need to recompile GRBL with the Z-axis homing disabled)

But as a newbie, I don’t know how to Flash the device and recompile GRBL.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.