Atomstack X7 Pro Home is 1,1 not 0,0

On my Atomstack X7 Pro I have noticed that when I press , the laser moves to the lower left - as expected.

When I go to the Move tab and press it returns with X:1.00 Y:1.00

When I “Move to Position” X:0.00 Y:0.00 and press then press it returns with X:0.00 Y:0.00

Question: How do I get home to be at 0,0 instead of 1,1?

Reading thru the forum, i found some these commands and ran them. The results are below:

Thank you

Is there a particular reason you want this to be 0,0?

The source of this is likely based on the pull-off distance of the laser after homing. This is why you’re able to coax it to 0,0. If you went much farther than that you’d likely trigger a limit switch alarm.

Your Atomstack likely does not allow you to make any permanent changes to your GRBL configuration changes so anything you do would need to be repeated every time.

If you want to force it to 0,0 try issuing this in console after homing:

G92 X0 Y0

You may need to switch $10 to 0 for this to actually work.

Sure. I’ve I’m engraving and aligning to 0,0 and using absolute coordinates, shouldn’t it start on 0,0?

Absolute coords will work fine as long as the homing is completed. It’s not that 0,0 doesn’t exist, it’s that the laser after homing has moved out 1 mm more in each direction.

Also, When I’ve completed an etching or cutting and realized that I need to run it again, the laser is a little off from the initial run.
What I have learned is that subsequent runs of the laser are perfectly aligned with the 1st run if I run this sequence before pressing again:
Press , go to 0,0 , press to confirm its at 0,0

I believe the homing is completed since the laser moves to 0,0 and nudges out to 1,1 and stops. Or is there more to this?
Thank you!

This is odd and not likely directly related to post homing position being 1,1. This could be something random like 34,53 and should still allow for repeatable movements. It’s likely that you’re somehow missing steps somewhere. Curious how simply moving it to 0,0 relieves the problem though. You’re certain that you’re not triggering the homing switches at 0,0?

Homing cycle occurs in 2 major phases… fast movement toward the homing switches… once triggered the head will back-off and then reappraoch at a slower rate. Once engaged it will pull-off to the specific distance specified in $27.

I do have it set to ‘return to finish position’ x:0.0 y:0.0
would this trigger the homing switches?
I do not know the console commands. Is there a command I can use to check the current value of 34, 53 & 27?
Thank you!

It’s possible… but only if 0,0 is within the range of the switches. You would get an alarm on the Console if the switches were triggered.

You can check all GRBL settings by issuing $$ in Console. Alternatively you can see these values in Edit->Machine Settings.