Aufero 2 negative XY origin

hi, I have an Aufero 2 that I cant setup well.
my origin on lightburn is on the top left and I mounted the limit switches.
I modified $ 3, $ 20-21-22-23, $ 44 and the homing works perfectly, with move page I can move the laser head in the right directions but the machine remains in alarm 2 because the table values are negative X-390 Y- 390.
before giving up I tried various configurations, of origin and direction of movement of the axes, although I have the switches mounted on the top left as I want my home.
in these tests I have always had negative values of the origin.
to overcome this problem I had to build a macro which I called homing and it contains: $h and G92 X0 Y0
only in this way can I use the move tool on the table.
if when I start the machine I use the default homing button and not the macro, it happens that yes, the head goes to home in the upper left corner, perfetct pullup homing ready, but if i press button to go at the origin, the head crosses all the table in diagonal and goes to the corner bottom right.
this always with absolute coordinates and with the peripheral settings of the origin selected in the upper left corner.
it almost seems that the Aufero has a preset that determines the origin in the lower right and that this setting is not solved with dollars.
the homing macro G92 X0 Y0 at the moment is the only way I know to use this machine.

thank you for some suggestion helpful, I not understand if problem is me, Aufero or lightburn, never seen this problem before.

This morning I only solved the problem of the table measurements that made the macro homing reset when the laser head arrived in the opposite corner.
I sized the axes $130-131 to 400mm and the LB work table to 385mm
this way no longer lock the motion move tool.

remains the problem of the macro that I had to do every time to set G92 and reset the work table which otherwise would have the negative coordinates.

please help me.

sorry for edit post, I can’t fix it