Autofocus function

Hi, I was wondering, does anyone know if there is an option to get a signal in Lightburn or on the Ruida 644XS controler if autofocus is done? The table is slowly moving up when autofocusing, I have to check if the chain has stopped.

Not that I am aware of. You could click ‘Get Positions’ in the Move window and wait for the Z to be zero’d.

Thanks for the tip!

Hi everyone, I just enjoy Lightburn more every time I use it!
Still a lot of testing, reading and trying and more questions…
How can I adjust the height between the nozzle and material when using autofocus? its off about 3 mm (too high)

Focus test:
Why does the bed go up and down when doing a focus test?
I just goes up and down…

There’s a setting to optimize Z moves in the Device Settings - enable that and it won’t do the extra moves. It’s disabled for safety, just in case you have clamps or something else on the work area.

There is a value in Edit > Machine Settings called Focus Distance that you can adjust. It’s the difference between the limit switch trigger height and the actual laser height you want.

Thank You Oz, will try it and let you know!

Hi Oz,
changing the machine settings > focus distance does not help. i’ve tried to input smaller values but then the software does not write to the machine. If you use the arrows (with steps of 1) then the machine accepts the value, but nothing else happens with the auto focus distance.
what can I try next?

Are you on a Mac, and only changing that one setting? If so, try changing the value, then clicking on a different one before you click the ‘Write’ button.

Yes I’m on a Mac. But the thing is, the settings are in mm, am I correct? The bed doesn’t do anything when I put in 6,00 with the arrows. But when I read the machine the value is stil In there.

It should be mm, yes. I might have the purpose of that value wrong. Since focus is just homing the Z, you could also try changing the “Home Offset” value for the Z axis, which acts as a back-off once you’ve hit the limit switch. It should accomplish the same result.

Hi Oz, the homing value of mine reads 110,00mm I changed it to 100, but no result. distance stays the same.

I’ve been trying some more. If I set the homing value to 77,0 than I can get a shorter distance of 3,5 to 4 mm. For now it’s ok but I like to know why the machine is calculating the distance wrong.

You have never mentioned what kind of machine you have, and whether the Z axis of your machine has actually been calibrated for proper step sizes - has it? If you ask the Z axis to move 10mm down, do you get a 10mm move?

HI, I have a blue and white 100w SL-1060 Reci Laser with a Ruida 644XS controller. And I tried to set the distance to 100 in the move menu, but it doesn,t… it only moves 9 mm

So how do i fix this? Help is appreciated!

In Edit > Machine Settings, in the Vendor Settings area at the bottom, look for Z Motor. If you asked for 100mm and it only moved 9 mm, you need to change the step size value for the Z.

There will be a value there already. Take that value, divide by 100 (what you requested), and multiply by 9 (what you got instead) to get what that number should be. Then click the ‘Write’ button to commit the change back to the controller.

Hi, this option works, but the value from the vendor was 6,00 this divided by 100 and multiplied by 9 gives a new value of 0,54. If I then test the z-axis it "screems’ like a … The minimum value I can give is 1,0 otherwise the stepper motor gives a nasty sound. So for now I’ve set the default value of the vendor…

If the Z was never configured, it may not have appropriate speed limits, acceleration, or other settings - that would make the stepper skip.

That figures… so that’s the reason it doesn’t listen to commands properly on the z-axis.
thanks Oz.
I’ve sent an email to the supplier, asking for these settings. I hope I can get some answers

No usefull answer… they advice me to use RD-Works… hahaha. When I adjust the value of the step size, the z axis starts moving faster. but when I adjust it to the correct value, the stepper motor “screems” and doesn’t move. So I set it back to the numbers they put in there. what can I do next?

There are several settings, but the two important ones are going to be step size and max travel rate. If you have the step size too large, the system thinks it is moving farther than it actually is with each step, so it won’t make enough steps. As you lower the step size, the system will go the correct distance, but will take the steps faster to keep up with the speed you’ve chosen.

Use a small speed value, like 3mm/sec, and a low acceleration, like 10mm/sec^2 - Z tables don’t move fast, and can’t accelerate fast either. Once you get it moving the proper distance, then you can adjust the max speed up until it starts to skip, and then pull it back down from there.

1 Like