Black image importing from svg or pdf

Hi all,

When I get a pdf that doesn’t load correctly into Lightburn I usually use Inkscape to convert that pdf into a svg so it can load into Lightburn. In some cases, though, when the original pdf has embedded images, after doing the conversion, those images appear as black box in Lightburn. The svg looks well into Inkscape so I’m assuming is Lightburn that is not handling correctly the svg. Any known issue or clue on what can be the problem and how to solve it?

I’m using Lightburn 0.9.23 on GNU/Linux.

Thanks in advance.

Having the same problem here as well with the PDF’s at least most of them… Until a week ago no problem to import a pdf and could do a traceimage without a problem.
The work around i use now is to open the PDF in Adobe Illustrator and save it as an illustrator file (ai) This illustrator file wil import and i can trace it again. LB 09.24 Win10

I am able to ‘Open’ multi-page PDF with images, using our latest 9.24 release, without issue.

I have the same problem with 0.9.24. Note that the problem is not opening multi-pages pdf but not showing the images in certain pdfs. I found that some work and others don’t work. Let me attach what I see.

Hi,
I have no idea if this would help in any way but have you ever tried to export your image from Inkscape as anything else like a jpg or png, once all the elements are cemented to one plane instead of vector elements it might help. Then you can use the trace function in either Inkscape or lightburn to convert it to a svg to allow lossless scaling?
Just throwing an idea out there.

If you are willing, post that file here for review. Or you can send to support@lightburnsoftware.com, include a link to this post for reference, and we can review the file.

this is what the pdf looks like in lightburn import

and this how it looks like in acrobat

i mail you the pdf…to the mailadres as mentioned.

best regards
eduard engel

Thank you, We will look into what is happening here and get back. This may take a little, we are moving our Corporate HQ, so things are a bit pulled apart right now. :wink:

Have you tried removing only the black square? (ungroup if neccesary)

It is not a group. I do find that if I view this PDF using the built-in MacOS Preview tool and then do a ‘Save As PDF’ to resave this file, I can then successfully import or open in LightBurn. But we are looking into why the shared file is having issues. :slight_smile: Thank you.

I just send also the pdf that has problems. Unfortunately, uploading pdf files here is not allowed.

I am able to ‘Open’ and ‘Import’ this file into LightBurn. I do not see “black squares” in the file when viewed in multiple software applications.

Sorry, sent the wrong pdf. I sent another email with the one that fails for me. Sorry about that.

Yes, I now see the same, thank you.