Boolean Assistant freezes up after I upgraded to v1.4.0.1

Love the Boolean Assistant but it stopped working when I upgraded to v1.4.0.1.
I’m on Windows 10 - what should I try to troubleshoot ?

How you are using it… I have 1.4.02 but went through 1.4.01 with no issues.

Are you only selecting two objects… ?

If you post the .lbrn2 file and tell us what you want to do we can probably help.

:smile_cat:

Boolean Assistant Problem.lbrn2 (16.2 KB)
See attached .lbn2 file

I upgraded to 1.4.0.2 to test but no luck.
The Assistant tool always worked before I upgraded and I’ve used it about 100 times prior.
The individual Boolean Tools in the toolbar work with no problem but as I click the Boolean Assistant Tool icon from the menu bar, Lightburn freezes up and I have to kill it through the Task Manager.

Hope you can help.

It should not do this and your title doesn’t really indicate this type of problem…

Not complaining at you, but this should be pointed out to @Rick, as he can probably advise something to help you out…

I assume you gave it a minute or two in order for it to be done working? Not saying it’s slow, but you system might be busy elsewhere…

Hang in there… :grimacing:

:smile_cat:

Thanks for the feedback @jkwilborn

I fixed the title.

I have left it for a long time before killing through Task Manager. Before this issue, the Assistant loaded instantaneously on the same machine.

I will try it on my laptop to see if I the problem reoccurs there as well.

Usually does… can you post your software and version… They will probably need that to duplicate your problem…

:smile_cat:

LightBurnLog.txt (133.7 KB)

Enabled the Debug Log and attached the Debug file when the problem happened - hope this helps in troubleshooting.

Will look at the log file, but I am not seeing an issue with Boolean Assistant. After loading your file, I am able to select two shapes and then select Boolean Assistant from the menu. All working as expected. Click on image to enlarge. :slight_smile:

-

-

If willing, we have our latest 1.4.02 public beta available you can test with. Would be interesting to see if you get the same using this beta.

I tried the latest v1.4.02 beta and the problem remains - no change from before.

Please try again with our latest 1.4.03 release and provide any logs / reports produced if this still hangs. :slight_smile:

While I know this information is not directly helping you address what you are experiencing, I am not seeing the same and things are working as expected on this end.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.