Boot/Startup time

Just curious… my machine takes 20 seconds for LB to start up from click to fully running. I have an AMD quad core, MSI MB, 8 gig ram with Win 7. LB is loaded on an SSD drive. Also takes about the same time on my new laptop with I5 processor and SSD running Win 10. Seems like forever when waiting for it to get done. It has always been like this since first install. These days though, we want instantaneous I guess… might just be me

Set it to start up when the computer turns on. Then don’t ever close it.

My i5 laptop with an SSD takes about 2 - 3 seconds for LightBurn to load. Something is not right with the state of health of your computer I think. Are you using networked storage for the files you create? Because I do find a delay loading files when I grab a file off my network and not the local machine.

1 Like

My MacBookPro from SDD…same as Anthony, about 2 - 3 seconds from launch click to fully running.

GOM. doesn’t seem to make a difference if I open over the network or locally. In fact there is no difference if I just run the bare program as opposed to clicking a .lbn file.My pc’s are healthy and well maintained.
Ok I will have to check into my machines if that’s everyone else’s normal time. I think there is internet license verification on start up as well. That may be a factor. Thanks

LightBurn only checks the license server every couple months, so if you are seeing a slow launch every time, something else is going on. We can also do fully offline activation, which will mean it doesn’t check at all, if you still suspect this is an issue for your setup…

I take back part of it. The laptop is at a 2 sec startup time so there must be something with the desktop. Tried running as administrator and in Win 7 compatibility mode but no help. Will check into it further.
Anyone else running Win 7?

Let me see if I can explain this…
It was/is the shortcut causing issues. Clicking the .exe opens the program in 2 seconds. Right click the .exe and choose 'Pin to Start Menu. Clicking the icon in the start menu opens in 2 sec. I deleted my shortcut on the desktop. Right clicked the .exe and clicked create shortcut. Clicking the newly created shortcut takes 20 seconds to open LB whether the shortcut is in the program location or on the desktop.

So what I did was drag the icon from the start menu onto the desktop and that starts in 2 seconds. Odd behavior for a shortcut… never experienced this before. I am A+ certified and been building pc’s since the DOS days so I do have some experience. I am getting old though :slight_smile:

I tried some other .exe creating shortcuts and they behave normally… normal speed.

I’m running Win7, and Lightburn definitely doesn’t start up in 2-3 seconds. I’ve never timed it, but it’s kinda slow. I never bothered worrying about it though, because once its up, I don’t turn it off until end of day, and it’s just part of my startup routine to go turn on fans, lasers, etc after the PC.

I’ll time it next week if I can remember, and post back with laptop specs, etc.

Blake, try what I did above and see if the same rings true for you. (click the .exe)

Clicking a .lbn file still takes 20 seconds

Thanx for this. I was also having the long start-up, and this fixed it

The only thing I can think of that might cause a delay would be if the shortcut included a filename or something that was on a network drive that was offline or something like that. LightBurn’s startup time is 2 to 3 seconds, tops, and the licensing check happens in a background thread.

I’ve been through my entire install… cleaned up all the temp files etc. I log out twice a week for garbage collection. Visited msconfig and checked that nothing was starting up that shouldn’t and checked all running processes. Also tried disabling anti virus. It is always starting under 20 seconds now but its not consistent. Occasionally it will be 2 seconds but mostly its 6 or 8 and sometimes 16. Same thing when clicking the .exe… Don’t know what else to do for now. Will ponder on it. Not a big deal but that’s just me in need for answers.

I have no network in my shop, no wi-fi, nothing

Ray, are you running Win 7?

no, I am using win 10