Bug or feature - group option?

I’m really desperate today because two objects did not have the position in the output which was shown in the Lightburn preview.

After a long time of trial and error I found out that you MUST group the objects !! If you don’t group them, they will be output offset.

Sometimes even 0.5 mm between “almost good” and “completely wrong” is enough.

I guess that this behaviour is not necessarily intended in Lightburn - is it?


You have an issue with your machine slipping or losing steps. There is no such grouping behavior in LightBurn. If you “save GCode” between the two different files (one grouped, one not) they are probably just run in a slightly different order, and that difference in the order might be helping your machine not skip.

Run your saved GCode from LightBurn in an online GCode simulator to prove it.


But there is a “Group” option.

This is when I select several objects - in this case the text and the circle - together and right-click the option “Group”.

If I do not do this, the text and the circle will be offset.

If I mark everything and say “Group”, the text and the circle will be lasered exactly as in the preview of the software.


Save the GCode using the two different options you’re talking about. Open each file in a text editor, then copy and paste the text into an online simulator if you don’t believe me:

They’re the same. The difference is in the order your machine will run them, and a different order can sometimes be the difference between skipping and not skipping if your settings are too aggressive for the machine, or the machine is loose.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.