Bug report: Inconsistent application of system locale for numerical display and entry

Being Swedish, one thing that sticks out often in software is when they aren’t respecting the system locale for numerical entry. We use the , (comma) as decimal separator instead of the . (period) used in English. It becomes extremely obvious because we can’t use the numpad comma to enter decimal numbers, but instead have to stretch over the keyboard to reach the period key. Lightburn is currently quite erratic on this so I took the time to go through every dialog I could find to see what is correct and what’s wrong, and I made this list. I’m not sure it’s exhaustive but I tried to find as many places as I could:

Mac version is 0.9.09 latest release version.
Windows version is the 0.9.09 camera compatibility beta.

When testing this for yourself, it can be a good idea to go in to language/locale settings on your computer and temporarily change the decimal separator to something very, instantly obviously wrong, like the letter “x” or a unicode smiley (which for me renders as a black diamond with a question mark in Lightburn).

Wrong on both platforms:

  • Top toolbar xpos, ypos, width, height, % scale boxes, font height, hspace, vspace.
  • Spd/Pwr display in layer list
  • Interval box in Cuts panel
  • Distance Threshold display in Close Paths
  • Display table for scanning offset in Device Settings (the actual edit box is fine on Mac only, wrong on PC)
  • Default font height in Settings/File settings
  • Everything in camera trace
  • Playback speed multiplier display in preview simulator
  • “Get Position” coordinate display in move tab (entry boxes are fine)
  • Everything on the main window bottom status bar

Wrong only on Windows:

  • Everything in Settings, both display & units and file settings
  • Everything in Cut Settings editor
  • Everything in Device Settings, both tabs, including scan offset entry box
  • Everything in Camera Alignment Wizard
  • Everything in Rotary Setup
  • Everything in Focus Test
  • Everything in Grid and Circular array
  • Everything in Offset tool

Wrong only on Mac:

  • Left toolbar Radius entry box
  • Default font height in Display and Units part of Settings (everything else is correct on Mac but all wrong on PC)

Correct on both:

  • Top toolbar Rotate (though it should have a degrees symbol next to it since all other boxes have units indicated)
  • Everything in “Move” panel except coordinate display
  • Everything in Camera Control
  • Everything in Shape Properties
  • Everything in Cuts panel except “Interval” and the layer table
  • Everything in Machine Settings

PS: Some software additionally helps with this problem by accepting both comma and period in entry boxes (presumably along with whatever the correct separator is, should it be different) and silently converting it to the system appropriate decimal separator - it helps a lot because this problem is common enough that some of us learn to reflexively use the period key for entry and it’s annoying to have the software reject our input because the software did it right and we’ve been conditioned to do it wrong :slight_smile:.

This is known, and “fixed” for the next release - All entry boxes now take only the decimal point. I’ve tried to make them all take the comma, but quite a few of the controls are being really stubborn and won’t do it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.