Burning between Shapes

I must be going nuts! Up until today I’ve been having no issues that I couldn’t resolve with the software. Today I downloaded the new version and the first thing I did was make some basic shapes to just “check things”. When I burn the shapes I’ve made on the board, the laser does turn off between the shapes making a transverse line to the next shape. Also, I have to “choose” what I want to burn. I don’t remember having to do this yesterday. I pulled up a file made last week and it required that I select what I wanted to burn, but I didn’t select the whole thing and it only burned the selected portion. Am I missing something?
Thank you,

If the software is burning between shapes, it means you don’t have Laser Mode enabled ($32 is not set to 1). If your machine serves as both a CNC and a laser, you probably used the CNC and haven’t set it back to laser mode.

For the other issue, make sure this switch is off in the ‘Laser’ window:

Thank you. Just prior to your reply, I actually was able to fix both as you indicated. I probably flipped the switch to cut selected graphics, however other than just installing the new version, I hadn’t made any laser/CNC changes - don’t even know if that’s something I have. Are you saying that LightBurn can be used for the CNC?
I appreciate your help and patience while I am learning. It’s still all pretty new.

No, but some other software, used for laser engraving or CNC use, might reset the controller settings. In fact, some makers of the controllers have the firmware reset itself to defaults when it reboots, which is irritating.

One last question, are there any GRBL settings that need to be changed for light output? Since using the new version every thing I make is much lighter, ie, not burning as much as it did yesterday. The image is there but very light.
Thank you

The common GRBL settings are here:

Read through the 1st paragraph and check the settings shown.

Thanks again. I found two settings had changed after installing the newest LightBurn version. The $32 value was changed and after setting it back to 1 the paths between the shapes stopped. The second change I had to make was setting the S-value max back to 255. In the Edit/Machine Settings window, the $30 value was 1000, which wouldn’t allow full power to the laser, as I understand it. I reset it to 255 and all seems to be working fine now. The S-value max under the Machine settings icon was correct at 255 but the other must have over-ridden that entry.

There isn’t a ‘correct’ setting for the $30 parameter / S-value, they just have to match. 1000 is the GRBL default, but some software authors are lazy and prefer 255 because it means they can read a value directly from a grayscale image and send that as the power value (8 bits is 0 to 255).

I have been battling this same issue on my 1830 GRBL 5W diode engraver. When I have $32 set to 0 I have plenty of power to cut. I am able to run 70% power 100 in/min and do a good job on card board. I now want to do text not filled and noticed there were connecting lines between letters. I invoked the $32=1 $30=255 and S=255 and now the laser is so week it wont engrave. I have increase laser to 100% and reduced speed to less than 50 in/min just to get a readable image (25in/min to be usable). I notice the laser now seems to vary as the letters are outlined and definitely not as bright as when $32=0. Laser PWM I am sure is kicking in but I think the pulsing is too fast or too slow. Is there a way to vary the PWM or other way to increase power and thus increase speed.

If it’s dimmer when you have $32=1, you’re asking the laser to move faster than your maximum speed setting in the firmware, and it’s reducing the power output to compensate for the fact that it’s not moving as fast.

Read though this guide for setting up a 3018 CNC - I’m guessing an “1830” is the same, just with the axis sizes flipped:

Thanks OZ
Reviewed the speed limits in the CNC machine and they were 1000 mm/min (39 in/min), too slow for laser. Increased to 4000 and worked great for laser but rapid returns could not be handled by 3018 servos. Reduced to 3000 ( 117 in/min) and dialed back on laser power just a bit and now works very good.
Been racking my head on this for weeks, I wish I had asked earlier.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.