Burning when not wanted

I have changed K40 controller to AwesomeTechs Mini GRBL then happily paid for Lightburn (awesome software BTW) and have had 2 issues:

  • Fill non burn movements are burning cutting is fine after I changed to a different GRBL.
  • Framing laser is on (and marking).

Some help would be great :+1:t2: Loving Lightburn!!!

I wonder if there is some mismatch in your settings, can you send more information or screenshots of the problem itself ?, I would like to help you.

Thanks will do, tomorrow :+1:t2: Thanks

Did you follow their recommendations for setup?


Yes checked all of the guidelines. I’ll recheck them though :+1:t2:

Darren do you want to compare your $$ values with mine, to begin with? I have a fairly normal K40 with Mini-Gerbil, but without problems :wink:

$0=10 $1=255 $2=0 $3=1 $4=0 $5=1 $6=0 $7=0 (ATC M6, pulse/ff) $8=100 (ATC Tool Td, milliseconds) $9=100 (ATC M6 Td, milliseconds) $10=1 $11=0.010 $12=0.002 $13=0 $19=0 (Softstart, milliseconds) $20=0 $21=0 $22=1 $23=3 $24=2000.000 $25=2000.000 $26=250 $27=4.000 $28=5 (Spindle freq. 0 to 15) $30=1000 $31=1 $32=1 $100=157.000 (x:stp/mm) $101=157.000 (y:stp/mm) $102=160.000 (z:stp/mm) $103=160.000 (a:stp/mm) $104=160.000 (b:stp/mm) $110=12000.000 (x:mm/min) $111=5000.000 (y:mm/min) $112=5000.000 (z:mm/min) $113=5000.000 (a:mm/min) $114=5000.000 (b:mm/min) $120=8000.000 (x:mm/s^2) $121=3000.000 (y:mm/s^2) $122=3000.000 (z:mm/s^2) $123=3000.000 (a:mm/s^2) $124=3000.000 (b:mm/s^2) $130=320.000 (x:mm max) $131=230.000 (y:mm max) $132=200.000 (z:mm max) $133=200.000 (a:mm max) $134=200.000 (b:mm max) ok

Darren, my $$ settings are identical to yours, so let’s look at your LightBurn settings.
Try making a simple little sample project and submit here. (the .lbrn itself)

Hi, Heres the file I started to use fill with and had the issues. I am using the Grbl-M3 profile as the standard Grbl one was burning the “non burning” transfer moves. Tried the $32=1 command in the console but that didn’t solve it so moved to the M3 driver which largely solved that issue and gave me this one.

VisaPaymentsWelcome.lbrn (162.6 KB)

Heres a couple of pics of a test file I’m using, the blue line is a 10% fill which is resulting in the photo below…So the laser on in the movements.

Got it sussed! I em ailed Awesometech and after a couple of days they came back with the driver must be GRBL STM and that I must check the $$ to follow the instructions of “laser stuck on” on Mini Gerbil debugging – Laser operation – AwesomeTech also to check no cables had come loose…I checked the PWM cable was loose I secured it and tested…ALL PERFECT!

Thanks for all your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.