Burnt dots laser starting and stopping

I’m a newbie to the laser world. I have a eleskmaker laser 40w my problem is burnt dots on starting and stopping of the laser. I have adjusted power and speed , tried some other adjustment in devices and settings and machine setup with no results. any help would be great thanks

I am not aware EleksMaker produced a 40-watt laser system. Can you please provide a link so I can learn?

All of the EleksMaker systems I am familiar with are small DIY type diode laser systems running some flavor of GRBL.

I was told it was a 40 w I’m using grbl - m3 and com3

Please post you GRBL settings for review.

thanks alot for reply rick like i said i’m new to this . I really dont know what your asking for

Ah, well this is the fun part of DIY. You get to learn something new. I have not been through the process myself but know the following has been of help to many others. Here is great resource for your setup.


As another member previously posted, “Scroll down to the bottom “operating instructions” and follow that. Once you have it working in elekscam, it should work in lightburn. Follow the instructions to the letter and that will get you up and running…”

thanks alot rick i’ll give it a try.It is a learning process I do have some of my settings now. Just let me know which ones you would like to see. again thanks

Go ahead and walk through the process I linked and we can go from there. Let us know how you get on. :slight_smile:

GRBL-M3 is the problem - It doesn’t vary the output power as the speed changes, so when starting, stopping, or slowing for corners, you’ll get darker burns. You should flash the controller with GRBL-1.1f or higher, and enable Laser Mode ($32=1) to get speed-adjusted power output.

thanks for the reply, I download t2 and everthing worked fine useing grbl 1.1e. Went back to LB and tried again,this time with grbl and com 3 and it worked fine no more burnt dots. I think I’m on the right track now. Is grbl m-3 1.1e the same as 1.1e ? How do I get grbl 1.1e on LB it is not listed in my devices.

Are you saying that when you try to add a device profile using the manual process you are not presented with an option to add GRBL-M3?


GRBL-M3 is a driver in LightBurn. It generates GCode for GRBL devices using the M3 (constant power) command instead of M4 (variable power). Versions of GRBL older than 1.1e do not support the M4 command, and will produce burnt start / end points.

GRBL 1.1e, 1.1f, 0.9, etc are just different versions of GRBL firmware. You don’t “get GRBL 1.1e on LightBurn” - it’s the firmware running the board - you just talk to it with LightBurn, using either the GRBL-M3 driver (constant power, will leave burn marks) or the GRBL driver (uses variable power, which varies the beam power as the speed changes, and doesn’t leave burn marks).

yes I do have the grbl m3 (1.1e) I’m using the grbl now and its working fine, Iwent to eleskmaker website and learned a lot thanks for all your help

thanks for the help and explaining this to me everthing is working fine now using the grbl and com3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.