Calibrating a rotary attachment

Hi, I see that I’m not the only one having difficulty with a Ruida controller and rotary attachment, but I haven’t been able to find the solution in other threads.

My attachment has a 57BYGH350 stepper motor, which has 300 steps per revolution according to the datasheet. The rollers are 1.5in in diameter and the test part is 2.625in. I believe the laser is controlled by a Ruida 644XG controller, although I don’t actually see a model number on the controller, this is just what Lightburn detects.

The rotary attachment functions just fine, it’s the calibration that is off, and no matter how I adjust the parameters in the tools -> rotary setup dialog, nothing seems to change. I’m testing the part in the picture by attempting to engrave a line that is the same length of the circumference (8.25 in), but the part spins exactly 4 complete revolutions rather than 1 complete revolution. When I try to compensate for this by changing the number of steps per revolution from 300 to 1200, nothing changes, I still get 4 complete revolutions of the part. I’ve tried turning the machine off and on and confirming that the modified settings are saved, and they are.

I know I can squash my images to 25% to compensate for this problem, but I would love to be able to get this properly solved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.