Calibrating new laser build, first time using ruida


I’m new to Ruida controllers and I’ve had a search around the net an can’t quite find what I’m looking for so I thought I’d ask here as i don’t even want to install rdworks if i can help it.

I’ve just built my new laser well up to x y stage, the LPSU is not connected yet. Everything’s gone fine apart from I can’t figure out how to calibrate my x and y so it’s the same in the physical realm as on the controller?

I’ve watched videos on calibrating the cuts by going into rdworks, but thats not what i want to do.

-Im using dc:9-42vdc driver set on 16 micro steps, pulse 3200 (I’ve got a big gear off both the pulleys). If i go up on the steps/pulse it makes it farther out. I believe my amperage is set correct. 24 volt set up


-Latest lightburn update

-My bed size in x 1264mm y 716mm but on my controller its showing x 1062mm y 497mm.

Is this anything I can do in lightburn or on the ruida controller or is it something I’ll have to wait till I can cut?

If I’ve left any info out that would help please pull me up on it.

Thanks in advance.

1.8 degree stepper motors forgot…

Hi James,

You don’t need to be able to cut just to configure motion. You need to go into the machine settings and adjust the steps/distance. You will have to set it for each axis. It is easier to do if the laser can cut a line. You would draw a rectangle of known size, run the job, measure what you actually got, adjust steps up or down as needed, and repeat until what you draw is what you get.

In LightBurn go to Edit > Machine Settings, then scroll to the bottom to the Vendor Settings area and expand it. In there you’ll find max travel values for the X and Y axis, as well as step lengths, homing directions, etc. If this is a new install you’ll likely spend an hour or so in there tweaking things until the setup is correct.

Thanks Oz, I shall give it a go later. Cheers kevin

Just done it Oz, tad more than an hour. Not a master like you. :grinning:

New x steps 7.498
New y steps 9.100

Need a fine tune when I’ve got the laser going, thanks for your help, always appreciated…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.