Camera problem in LB 1.2.01 unter LINUX


I bought a regular licensed LightBurn 1.2.01 and installed it under Linux.
After help I can also control my Sulpfun S9 with LB (see ‘My Laser is not recognized by Lightburn V1.2.01’). So far so good.

I have installed a camera in my case and am now trying to use it, which I am not yet able to do.

The camera is OK and is recognized by the OS.

reinhard@W520:~ $ lsusb

Bus 001 Device 006: ID 090c:f37d Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Endoscope camera

With a webcam application e.g. ‘cheese’ it works fine.

With LB I can also select the camera and the dialog also shows that it is recognized, but the image shown is completely black. If I deselect the camera, i.e. ‘none’, the black image disappears and if I select the camera again, the black image is shown again.

If I select the button ‘Track’ in the ‘Camera configuration’ a nice picture of my work area is shown with the camera.

So the camera is also running in LB but not in the configuration dialog and I am not able to calibrate it.

Where is the problem in LB and how to change it so LB has the features I bought? What can I do?
The camera is connected directly to the USB port of the W520. I have also tried the 2nd.


I have a similar problem, as a temporary hack piping the image through ffmpeg helps:

Need a loopdevice for that. Hope there will be a fix in a newer version, maybe just changing the build platform would help. Ubuntu 16.04 is “a little bit” old…

Hello ‘doppelgrau’
thank you for the quick answer.
Unfortunately I don’t understand the command and I’m not the Linux-specialist either. I haven’t worked with ffmpeg yet and I don’t want to fiddle around endlessly.
However, I have found a solution to my problem by changing the graphics driver from ‘nvidea’ to the ‘nouveau’ driver, which seems to work with the configuration of the camera.
I’m satisfied for now and will let you know if any new problems arise.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.