Can not adjust pattern when using Chuck rotary

I attached my rotary and went through the steps to set it up. When I click the test button, it moves along the x-axis about 1 inch and stops. I tried engraving a 25.4 x 25.4 mm square, and the square measures 25.4 mm x 152.4 mm. Every pattern I try, even a simple box in Lightburn, is stretched along the y-axis. I went back and double-checked my steps per rotation, and according to my machine should be (6400*2) 12,800 still nothing. I changed my steps per rotation to 360, 1,000, 2,000, 6,400, and 10,000, and the image still stretched to 152.4mm. Do you think it is possible that I need an update on the firmware for the controller? Your thoughts? I have a Cloudray with Ruida Controller RDX644XG
Model: CR Series (55W-100W) CO2 Laser Cutting Machine with Industrial Chiller / 100W CR7050-C (Linear guide)
Model: Cloudray Model B Rotary Engraving Attachment with Chucks (Model B with 2-Phase Motor)

You need to be able to use the test button on the gui to get the required one complete rotation and back…

Does your rotary have a belt/pulley or direct drive?

Here is a setup, did you do it this way or?

If you have issues, let us know…

Good luck


I have hit the test button several times. On the first hit, the laser head would move about an inch. I’ll hit it again with the same movement. On the third time hitting the test button the rotary would rotate 360 both directions. I even set up 1’’ by 1’’ square to test. Both X movements would measure 1’‘, but the Y movements would stretch to 6’'. My rotary is belt driven.

Yes, I am understanding better. My dip switches (from 5-8) shows 6400. My ratio through my research on the Chuck Rotary showed 2-1. I am going to give it another go. I am just baffled that I have not made any progress. I even thought maybe the communication from the Ruida Controller and the Lightburn program could be off. I had the acceleration speed at 20. I will try the single digits as well.

Make sure you’re oriented in the correct direction for the motor driver switches… I always feel it’s inverted… it’s labeled on the switch…



This is my setup. I tried to send a video showing my Rotary spinning about 5 times around and then back when I hit the test button. If I can figure out how to post it, I will include it.

You can put a file, any kind on something like your google drive and post the link to it here. Don’t forget to allow anyone with the link to read it…

I cannot tell what your switches are set… it requires information on the placard of the drive… not all drivers have the same steps …

I assume the two photos are the two motor drivers… if we’re using only the Y axes, that’s all we’re interested in… no need to deal with any other axes…

What kind of motor driver is it?

In the link, you can see the type of motor driver and placard that indicates what the switch settings are doing… Mine is a DM556 motor driver…


When I get home, I will tell you what kind it is. However from 5-8, it shows off , on, off, on. This brings it to 6400. So I took 6400*2(12,800) and plugged it in. But I’ll tell you when I get home. Thanks for your assistance.

How did you come up with the translation from switches to steps?


That’s the thing all my research seems to tell me that 5 is Off; 6 is ON; 7 is OFF; and 8 is ON. I looked at the chart and the value is 6400. Am I looking at this wrong? Thoughts?

Looks correct… It’s hard to fix some things if you assume the previous steps were taken correctly. and they were not… so it’s a sanity check if nothing else…

Have you counted the teeth on both of the pulleys to ensure it’s a 2:1 ratio?

The best tactic may be to start at the digital end and work to ensure that the motor itself is rotating 1 complete rotation and back with the test button … without any ratio adjustments.

Setting your rotary to the same step/rotation as the placard you can test at the motor… it will be right or it won’t…

Make sense?


I hope you are able to open this file.

Is this just pressing the test button?

Did you try and look at the motor to see if it’s responding to the test button correctly, as I mentioned in the previous post?


That is me hitting the TEST button on Lightburn. And even when I change the values, it does the same. It is almost as if the communication between the Lightburn software is not communicating with the Rudia controller software when I hook up the Rotary. However, when I load the original file back, the machine works great.

This is what Cloudray sent me:
.Loading Google Sheets

The one thing that stuck out to me was disabling the Y homing. But correct me if I am wrong. I thought it would auto-disconnect when I connected the rotary. The first thing I did was set the parameters, power down, connect the Rotary, and power up the machine.

Somethings not right there should be no head movement… only the rotary.

I have no idea what OMTech sent you… some of those parameters are in the machine settings… I would doubt you would need to modify any other than steps/rotation to get this operational.

I can’t tell when you’re pressing the test button, but it doesn’t appear to be working.

The machine works fine in it’s original configuration without the rotary…?

I can’t think of any common cause to explain how it’s operating…

They seem to indicate that it’s 6400 steps/rotation not 2 times that.

Is that what it was set to when the video was taken?


Yes, the machine works great to your first question. Second question, I would run the test at 6400 and 12,800. When you saw the laser move that is when i was hitting the test button. After hitting the test button at the third time, the rotary would spin. I am banking on the fact i am doing something wrong. The instructions are very clear on how to set up the rotary. I have to say disabling the Y homing is something have not done. Those instructions came from Cloudray.

I’d follow Cloud Ray advise… it’s usually not awful…

Something is wrong if you move the Y axes and the X axes also moves. The control keys should only work that specific axes.

Do you get the same results for both 6400 and 12800?

It should be the 6400 according to the data they sent you. No ratio…

Is this right… there isn’t a gear ratio or pully belt internally?


I just wanted to let you all know that I figured it out. I looked over the information that Cloudray sent me. In Lightburn (1.4 version) I adjusted the “Length Per Step.” I opened up “Calibrated Axis” in the Lightburn “Machine Settings.” I typed in the values Cloudray provided and hit the Write button. So, the value in the Request Distance (1.3821) gave me the 21.6623. This was the value that worked for me. I will continue to work with it and make sure I am on track. I really appreciate your assistance.

We appreciate you’re keeping us up to date with how you are correcting the issue…

Good luck