Can not connect my laser

Hello. I am desperate. Since the purchase of my laser and Lightburn I can not use my Laser properly for one day. I have Atomstack X20 Pro 120W. I purchased Lightburn. It is a nightmare to connect the laser every time I:
-shut down the computer
-turn off the laser itself
-quit Lightburn.
It requires numerous restarts to be lucky and connect.
FIrst I had the error There was a problem sending data to the laser. The Machine may be busy or paused
Then: Port Failed to Open Already in use? Error Message
Then after hours of reading possible solutions in this forum, I decided to remove the laser and add it again. Impossible. LightBurn just doesn’t find the laser again. Tried manual adding. Nothing happens. I have GRBL installed as well as the CH340 drivers. Please, LightBurn team, provide me with some kind of solution, because this is not what I paid for.
LaserGRBL communicates with the machine flawlessly.

Try this:

  1. Make note of the COM port that the laser is assigned to. You can see this in the Laser window in LightBurn or on the top left in LaserGRBL
  2. Make sure that LaserGRBL or no other software that could potentially be running is attempting to attach to the laser
  3. Turn on the laser before opening LightBurn
  4. Open LightBurn and make sure that the previously identified COM port is showing in Laser window. If it is not, pull-down the field and select the correct port. Make sure that it’s not going to a different port not associated with the laser

If this does not work, please make note of any variance from this. Take screenshots of every stage of this process and upload here.

Hi! Thank you for your detailed and quick answer. I have tried this multiple times. I am no longer on the PC, as it is way past midnight. Something I forgot to mention: I have custom made PC with aRGB fans that turn off for a moment every time i turn off and on the laser. I hope this information is useful as well.

If you’re able to consistently connect with LaserGRBL you should be able to do so with LightBurn.

When you get back to it one thing to try is to enable “Enable DTR signal” in Edit->Device Settings.

How are the fans powered? Make sure you’re getting good clean power to the laser. Put this on a different circuit if required. It’s possible that the USB voltage is dropping for some reason and disconnecting momentariy. This shouldn’t be a problem if you follow the steps listed in my previous post however.

Thank you, I’ll try it tomorrow. The main problem now is that LightBurn doesn’t even find my laser anymore, and adding it manuall through GRBL profile doesn’t work either. I’ll post screenshots tomorrow.

and use a shielded USB cable will always help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.