Can not get my laser connected

I am a new user testing this tool.
I tested it before i got the laser and it seems to be what I want.

When connecting my laser (NEJE 2 20W) Lightburn do not find the laser.
I get the message “Waiting for connection”.

If i connect the laser to the software delivered with the laser it finds the laser and work as expected.

I am hoping for a fast answer to get started.


What is the controller in this machine?

.Is this the info you need?

LightBurn Software

NEJE Master2 supports LightBurn software with firmware GRBL1.1F.

LightBurn is a paid software. You can download it from the official website of Lightburn . This software is not developed by the NEJE team. You can use it for free for 30 days.

If the firmware on the machine is not GRBL 1.1f by default you would have to flash that firmware to the board first. There is a good chance that they ship it with Benbox or some other custom firmware of their own, but supply the tools to flash GRBL. Check the software it came with.

It was as you expected.
I have now managed to flash the firmware to “GRBL 1.1f”.
I then tried to let Light room identify the laser but it did not find any laser.
I tried to do it manually using selecting GRBL, USB and 170X170mm.
When connecting the laser it looked OK except for error: 5 in console.
What does this mean?

This is the official listing from the Grbl development site.

It was a very long explanation of error:5. Could you try to explain to me what to do to solve the problem. It is frustrating that the laser works OK stand alone and the software seems very nice but together they do not work.
I am definitly not an software expert. I understand it as there is a problem to identify the startingpoint of the laser, correct?
I have tried the differnt Origion under device but it always seems to try to go outside the range of the laser if I start with the laser in Origo.
I have also tried the different setting in the “Start from meny”, but it is not clear to me what it means,

Error:5 means “Homing cycle is not enabled via settings.” This is reported from your hardware and not LightBurn. Do you have limit switches installed for this setup?

What ‘Start From’ setting are you using?

Thank you for trying to help me to understand how it works.

The NEJE2 laser has a home button. If this is called upper left or whatever depends on how you move around the maschine.

The Y value goes to minus values when I move from the starting point.

I have tried the different “Starting from” settings and also the different settings for origin in the device settings.

I have manage to get the Move arrows to take the laser as expected and to set origo to the correct place but when i move in Y-direction the value gets negative.

Any idea how to solve this?

This is one of the annoying quirks of CNC versions of GRBL being used for lasers - GRBL defaults to negative workspace after homing, meaning that the work area of the machine is accessed using negative numbers. None of the DSP controllers LightBurn was originally written for support this, and GRBL used on most lasers doesn’t do this either.

You can move the origin in a couple of ways:

  1. Jog the laser to the front-left, then type G92 X0 Y0 in the console (and press enter) to set the current location as the new origin

  2. If you know the amount of offset from the home position to the origin, you can enter it directly using G10 L2 P1 X-### Y-### where the ### values are the negative X and Y offsets to move the origin by.

We talk about all of this here:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.