Can someone explain?

I have about a week to decide if this software is usable or a piece of junk, currently I’m leaning against the latter.

My machine is a Raw 1.5 with an Arduino Uno and (currently) a Chinese GRBLshield copy.
The gantry has 700x700mm of travel in X and Y direction and 90mm movement in the Z-axis.

Moving in the z axis is no problem but when I try to move as little as 1mm in either X or W I get this “error message” in the transcript window:

“Waiting for connection…
Grbl 1.1h [’$’ for help]
[MSG:’$H’|’X' to unlock] ok [MSG:Caution: Unlocked] ok [VER:1.1h.20190825:] [OPT:V,15,128] Target buffer size found ok Starting stream ALARM:2 G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the 'Devices' button to reset the connection) On or near line 3: Stream completed in 0:00 [MSG:Reset to continue] ok Grbl 1.1h ['’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

Is there any way to evalutare te actual G-code sent to the controller to try to figure out what goes wrong with X and Y byt not with Z???

That’s your controller telling you that you tried to move the X or Y axis out of bounds of the machine, and it stopped you from doing that instead of slamming into the rails.

I’ve looked up the machine and it appears to be a CNC, so most likely it’s meant to work in negative workspace. If it homes in the rear-right, you’ll need to set a workspace offset to move the origin to the front-left, which is basically the same as zeroing to the workpiece, except you’re zeroing to the entire work area of the laser instead.

The simplest way to do this is with a macro button in the console. Right click one of the macro buttons, then enter these commands:

G10 L2 P1 X-700 Y-700

And set the name to “Use Laser”. The first line offsets the zero so the origin is now front-left. The second line tells the controller to report position information relative to that zero point, and the third line enables laser mode in GRBL. After homing, click that macro button and things should just work after that. Let us know if you’re still having issues after this.

All of this is in our documentation here:

If you only have a week left in your trial because of this, post your trial ID here so we can extend it for you.

1 Like

Hi Oz,

Thank you for your fast reply!!!

From your input I found out that I could move the the axis negative from what was zero when the program initiated. At that point it looked like LightBurn seemed to believe my zero was is at the top right corner (not left bottom as specified in the Device Settings and all possible moves were negative from that point.

From that I figured out that I had managed to set Soft limits ($20) to true. As a result LightBurn did no longer care about my setting left bottom as zero in the Device Settings, with hard end stops enabled the gantry moves as expected!

I have 8 days left on my trial and need some more time to get acquainted with the program as I still have not manged to paint / burn anything with the program.

My trial ID is “7b8678ee-8b28-47f5-a488-a4738582b41b”

While I’m very sure that everyone on this forum are ladies and gentlemen, it’s probably not a good idea to post your private code.

Well, I did read the “post your trial ID here so we can extend it for you.” literally… my bad.

Sorry, I just re-read Oz’s post.
No worries.

Trial ID’s are safe to post - it’s just an identifier generated from a bunch of machine info. It’s not a license key that someone else can take. Never post a license key to the forum.

I’ve extended your trial.

What you’re describing about your negative workspace and the limits settings are exactly the things that the commands I gave above are to correct.

Thanks Oz, I will use the time well!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.