Can someone with a 6445G please check to see if you get this bizarre error on your Ruida?

Hello! I’m looking for someone (or someones) with a 6445G controller who would be very kind to test cut a simple file. I’ve had a weird misalignment problem that I’ve tried most everything to solve. I finally made a simple file with two rows of 20 lines that creates the problem so I could convince the manufacturer that this error exists.

They were able to replicate the error on their machines, and have checked with Ruida who gave them a run-around answer.

I need to know if the problem is just with this batch of Ruidas (mine and the company that I bought my laser-cutter from), or if it is all Ruida 6445Gs. If the file cuts correctly on someone else’s 6445G then I can get a new one (from a different batch!) and finally be free of this problem.

My machine misses alignment in the x-direction by about 0.1 mm in random, but repeatable places. In the simple file I’m hoping someone(s) can test, there are 20 line segments in a row, and 20 more line segments underneath, touching the top row. In one version (filename 20D), the cut order is set so that the top row and the bottom row both cut left to right. The line segments align exactly, as they should.

The second file (20B) is the exact same file with the cut order changed. In this one the top row cuts left to right and bottom row right to left. Shouldn’t make any difference… but on mine it does. The two rows of lines meet neatly at the two ends but not in the middle. Exact same file. Just a different cut order.

Here’s the files, in .rd and .rld format:

https://www.dropbox.com/sh/xjes6qmcpn59 … 0t-Pa?dl=0

(I use Lightburn on a Mac, but had to make these in RDWorks on a friend’s PC because the company kept telling me the problem was Lightburn, which I knew couldn’t be but I had to prove it to them).

If you have a 6445G and can check with an actual physical test cut, I would be extremely grateful. This is the key piece of information that I need to know if it is indeed just this batch of controllers, or all Ruida 6445Gs, or something else.

If you’re willing to try, I’d be happy to send you one of the wooden puzzles we design and produce. Thank you so much!

I just ran your 20B.rd file on a Ruida RDC6445G(EC) and the lines are correctly aligned. It has firmware RDC 15.01.22 and HMI 10.01.09. Brand new unit, purchased from Cloudray last month. Can you upgrade the firmware in your unit?

EDIT: Having said that, and looking more closely, there is definitely a slight difference between the two end lines and the center ones. Perhaps a small misalignment, but not as much as you are seeing.

Mike Wood you are my freaking hero. You have no idea the trials I’ve gone through trying to nail down this problem.

I don’t know how to install firmware or where to download the latest, but I’ll see what I can find. Looks like I need RDWorks to do so?

Thank you! Will pm you to arrange for sending a puzzle.

1 Like

I checked my firmware version, it is the same as yours. The manufacturer is too busy right now to help. I told them I was ordering a controller on my own and they agreed that if the new one works they will pay for it. Ordered from Cloudray this morning.

I have to say that, if the firmware is the same, I fear you will get the same result. It’s hard to think of a hardware fault with what is purely a digital device that would cause such a subtle change. I certainly understand you trying it though in an attempt to eliminate every possibility!

I’d also look at your stepper drivers and how you are talking to them. For example, have you looked at whether the Ruida is set to trigger motor steps on the rising or falling edge of the pulses? That being wrong can cause odd errors. Ruida calls it ‘PWM Rising Edge Valid’ and you can change it through Lightburn.

Maybe, but I’m out of things to try. I have tried countless combinations of rising edge valid on and off, all kinds of speed and accelleration settings, even down to a crawl. I have a double head laser and I removed one head to reduce mass. I’ve checked everything mechanical and the machine is very sound. I have a thread on lightburn somewhere and also rdworkslab and got lots of suggestions of things to try. Finally, with this file, I was able to get the factory to get the same result.

This is kind of my last chance. I’ll let you know how it goes!

By the way, how long did it take for your controller to arrive in the mail?

They shipped quickly within a day or two, but the Ruida was part of a large order which included a laser tube and the whole thing got held up by the FDA. Cloudray hadn’t provided the correct FDA paperwork so things got stuck until I provided it myself. That all cost me a few hundred dollars and another week… In my limited experience it wasn’t worth the trouble buying a laser tube direct from China to the US. By the time I’d paid customs import duties and brokerage fees it would have been cheaper, and simpler, to buy it here in the US.

You won’t have that problem with just a controller. :slight_smile:

If switching direction on one of the rows shifts it, the problem is most likely backlash. If I run your 20B rd file with my backlash sim enabled, you can see how the bottom lines are shifted relative to the top ones (the green lines):

Zoomed in a bit:

The black line is the actual commanded line from the file, and the green line is where the laser head ends up, lagging a bit because of the slack in the belt. It looks like yours is only on the X axis.

Hi, what about the way the right and left sides align exactly? And would fixing that just involve tightening the hell out of the belt? It’s already pretty snug.

Missed that bit - in that case I don’t have anything.

I would still look for a mechanical cause. I ran your file on my 6445G and don’t see any offset.Only some bulging where the two lines meet.

Ignore the clean lines between, I forgot to uncheck optimize path.

Thank you Joel. I’ve done a lot of mechanical checking (short of replacing steppers and the like) and since the factory got the same result as I did, either all of their machines have the same fatal flaw or it was the batch of controllers. That’s why I wanted someone to try it with the same controller, hoping it would print correctly and thus there may be a glitch in my controller. I’ll send you a puzzle too - thank you!

Hopefully it’s just a setup issue from the factory and not a serious problem. Just for completeness, things I would check ( some of which it seems you did ),

Belt tension ( not too tight, belts are actually pretty good for this application )
Mirrors tight in their holders
Mirror holders mounted tight
Focus lens tight
Focus lens tube not wiggling in final mirror mount
X carriage slop free on it’s rails ( cannot wiggle or rock back and forth )
Stepper pulleys tight on shafts ( picture the set screw a little loose on shaft flat so that the shaft turn a little before the pulley does )

Hope you get your machine going.

Hi Joel, yep, did all of those things. And the manufacturer when testing my files got the same error. They figured it was a controller error, but Ruida denied that. Tried to find out if the machine they tested had a controller from the same batch as my machine, but they were confused. If I could have gotten them to try the file on their machine with a different controller, could have determined whether it was controller or something in the set-up of the machine.

Their recommendation: Use RDworks, only with files you draw inside RDworks, and don’t specify any cut order. This is of course a no-go. On top of that, I have a fairly large number of complex files that cut fine on a Glowforge and an Epilog, No way I’m going to buy a PC, learn RDworks, and then attempt to redraw them in this software just to see if magically the machine works.

I really hope this controller has a crossed circuit… I’ll know shortly.

To me it looks like backlash OR a weak stepper driver. When micro-stepping is involved and the stepper is over or under driven it can cause a similar issue. You may be able to rotate it and test it along the Y axis vs the X axis and compare. Could possibly swap the X and Y drivers out as well. But as for the file, mine was able to run it without the issue and its the 6445G(EC) controller

1 Like