Can variable power be turned off?

I recently upgraded to a GRBL controller board, and it seems that the variable power is causing various failures that I didn’t have with the simple M2 and Whisperer. Im seeing corners skipped and portions of text (or other engraved lines) missing. Ive tried lead in and lead out and that either doesn’t so anything or the letters have long “hairs” on the line ends. It seems that a first order solution would be to make it work like the M2 board, and add the fancy later. Ideas?

Hi Dough…

Which one?

Googled “VMS GRBL controller” didn’t hit on any similar controller.

Did you do the Lightburn GRBL setup?

We need to ensure it’s not a configuration problem, so it needs to be set up properly.

Copy and paste or screenshot of the machine settings ($$ at the command window for grbl will print them out) or go to edit → machine setting, I think will work.

It’s best to copy and paste them in a .txt file. When you reply you can just drag and drop it on the window and it will upload it.

These are generally what’s needed for help, along with pc type, mac, windows, linux…? And the version of Lightburn Help → Quick help and notes → about.

I’d rather you make one trip than ask you multiple times… :wink:

Take care :slight_smile:


The issue is that GRBL is meant for diodes. CO2 lasers have a power point called an ionization threshold, below which they don’t fire. GRBL, by default, ramps the power down to 0 when it stops for corners, and your threshold is likely about 3 to 4%. I’m not sure if the VMS board has a setting for the minimum PWM, but if it does, increasing that would solve the problem. (Note that this is NOT what the $31 parameter is for)

Im running LB 1.001 (I think, just updated this morning). Mac OS Big Sur 11.5.2 with a VMS Laser Accessories LX4 board (Eric Norton). Here are the settings:











































Ok, I don’t have that constant power mode button in the cut settings editor, but it does have a minimum power dialog, so I guess that should do the same thing. What does $31 actually control?

You should not see the Min Power setting unless you’re using a DSP controller, like a Ruida. GCode based boards do not have this option.

Min Power is basically ‘corner power’, so if it’s too low (or zero), the laser will not fire at the corners.

$31 sets the value that GRBL uses to mean “zero output”, in much the same way that $30 is the value that means “maximum output”.

Im using the GRBL-LPC device type and I do have Power min% on my cuts/layers page.

Can you show me a screen shot of that? You shouldn’t have that control, and if you do, it’s likely a bug. You also said you don’t have Constant Power, which means you might be using an old version.

Also re-checked the version, its 1.0.01

Ok, that’s a bug. It should be suppressed for everything but grayscale image mode.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.