Cannot get lighbun to scan faster than 400mm

ok, i have both X and Y drivers using 2000 Stepsm and recalibrated. Working like a charm!
Thank you both!

Can we tackle the Z axis? :slight_smile:
Using a 23Nema motor, driving a belt to four T8 Screws. Driver set at 6400.
I calibrated LB correctly and can move within LB no problem, 1mm, 10mm, etc.

Question i have is, when i try and move from console, it doesnt do anything.
What is the procedure for tuning Z axis properly so i can move with LB and from console?

I’m glad it all worked out well for you so far! Your daughter must be happy having your machine (almost) ready for you and her! :slightly_smiling_face:

Regarding your Z issues, can you please check what firmware you currently have in the controller? It briefly came up on the display after any reset.

There is a Machine Setting in LightBurn (and only in LightBurn or RDWorks, you will not find that option on your controller) that has to be enabled or disabled dependent on your firmware version, I think all up to RDC-V15.01.15 (inclusive) will have this option to be disabled for the Z axis to work properly and all newer firmware versions need this to be enabled (as it should be). The option is this one:

Good luck and cheers,
Brian

Hi Brian,
I have version 15.01.22v. I tried that setting, but it made no difference.

I noticed that when i do press Z Down on the console, the display says its going down 5 or 6mm but the bed really doesn’t move. Works fine from LB.

Before i made the calibration for the proper movement, the um on the console was very low to be able to move from the console. Very wierd.

Hey Bob,

I realized just now that the mentioned setting regards only to the Auto Focus function that you probably don’t have or use?

So I have no clue why it works in LightBurn but not on the console.

Can you share your machine setting again? Mostly “Miscellaneous”, “Vendor Settings” and “Z Axis Settings”? And possibly the “Move” settings from within LightBurn?

grafik

What are you doing to move Z in LightBurn? Press those Z+ / Z- Buttons to move it the set distance? Does it actually move that set distance after that? What if you continuously press down the Z+ / Z- Buttons on the controller? Does it also continuously show movement without any actual movement or does the movement stop despite still pressing the Button?

Maybe together we can spot something that might cause that behaviour.

Good luck and cheers,
Brian

I’m moving Z from within LB. It does move the requested distance of 10mm. LB will move continuosly if i set it so.

Buttons on hte controller is where the problem lies. It does not move but you can hear motor.

If I calibrate with console the correct amount of movement, and use console keypad, movement is correct, but LB does not move the same using the LB movement keys.

If I calibrate with LB with the correct amount of movement, and use the LB keys, movement is correct, but console does not move the same using console keypad.

Its like both will not agree on the movement.



Hey Bob,

Can you elaborate a little more about the steps you are taking and what you mean with calibrate with console / LB?

You have set the Step Length for your Z Axis very low, combined with your mentioned driver setup for 6400 steps per rotation that might not get enough torque per step for the fairly heavy table (compared to the required X/Y Axis torque).

Furthermore, the Z-Speed can be set directly within LightBurn while the controller will always just use the current speed (for all Axis). So if 5.0 mm/s are working fine for you in LB (as it is set to on your screenshot) then set the speed on the controller to 5.0 mm/s as well and see if the Z Axis is working fine.
And if it is just set the Max speed for the Z Axis in the Z Axis Setting to 5 mm/s instead of 100 mm/s. I can’t image your motor will be able to move your table with 100 mm/s anyway. At least I would be highly impressed if it can. :slightly_smiling_face:

This will always limit the Z Axis speed to a maximum of 5.0 mm/s (or what ever is best for your machine) regardless of any higher speed setup in the controller (or LightBurn).

Good luck and cheers,
Brian

Thanks Brian, going to give your suggestions a try. In your opinion, what should the driver steps be? Is 6400 good or bad?

You are the man Brian!
I changed the “Jump off speed” to 5mm, “Max speed” 10mm, and not sure if this helped at all, but also the “start speed of key”

I also set driver at 400. Step is at 8.4um. LB working great and I am able to move bed with the console Keys.

Thanks for all your help!!

Now just need to work out some power setting issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.