Cannot get my laser to connect

I recently bought a new laptop (HP Windows 10) and after installing Lightburn I cannot get my laser/xcontroller to connect to Lightburn. I have installed the Multicommunication Port- COM4. I didnt have this problem with my MAC or other PC- so why am I having this issue with this computer?

things I have tried:
turning laser on before opening lightburn
restarting my laptop
uninstalling/reinstalling lightburn
updating lightburn
removing and manually creating GBRL (again)

anything else I can try?

Why? What prompted you to do this?

Without knowing much about the xcontroller, it sounds like you need a driver to find the serial port at the end of your USB.

When you plug it in, do you get an audible indication that the OS has detected a new device?

The reason you didn’t have the problem before was because they are different computers. Likely your PC already had the driver and the Mac likely didn’t need one.

Thanks for the link! I literally googled for 3 hours yesterday trying to get it to work.

nothing prompted me to do it but it also wasn’t popping up once i tried setting up the laser on lightburn.

it is making a noise when I connect it or disconnect it.

That worked! thank you!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.