Cannot get rotary to rotate

Hello, I purchased a 55 w OMTech laser with a Ruida 644XG controller months ago and the machine has been great. I recent bought a new rotary from Mansfield Customs and when i went to plug it in the Y axis, it will not rotate at all (the motor isnt buzzing or anything), on the controller or in LB. Im sure I’m doing something wrong but something seems off. Ive tried a multitude of things in the software and have written the rotary information to the controller via LB but I’m stuck.

Thanks for any help on this topic.

Message Mansfield customs. He usually gets back pretty quick.

It’s probably not wired properly. Mine worked, but ran backwards. Check the wiring to ensure it’s properly connected. Many of these Chinese machines have them wired different.

You can look at your motor driver a read off the wiring to double check your device.

Of course, you probably should act on @micrololin advise at the same time. Mansfield will probably ask you about your motors. Two or three phase and the connector wiring.

Good luck


I edited out the wiring in my post. I didn’t want a warranty voided.

I would think they would ask him. When I purchased my rotary they asked if I wanted the ‘standard’ wiring or a custom job for 15 or 20 bucks.

I would think they would like him to check it. Doesn’t have to disassemble anything that isn’t user ‘take apartable’. Look in the connector is about it.

I understand the warranty issue.


Thanks for the quick responses, The current y axis motor is a 4 pin (so i assume its 3 phase) the drivers are set to 2.36 RMS for the stepper motor and 2050 for the pulse/rev. Is there anything else I should be looking at wiring wise?

If it has 4 wires it’s 2 phase. 3 wires 3 phase.

I guess that’s I shouldn’t assume anything haha.

I may be wrong but that’s what Mansfield asked when I was inquiring about the rotary.

No, you are correct I just looked it up. I checked the wiring on the rotary and pin 1,2 are wired to a phase and 3,4 are wired to the other.

That sounds more like 2 phase. That’s what’s in mine, I had to rewire it, ran backwards…

My wiring is visible from the electronic bay side. You should be able to see the connections.

What kind of motor driver do you have?

I assume you didn’t change any of the switches…


Driver is a DM545A, no change to the switches, let me run out and double check the wiring to from the driver to the 4 pin connecter.

If one of the wires is switched it may not function at all. I suspect that is your issue.

Do you know the steps/rotation of the motor and the gear ratio? You will need them.

Good luck…


Where did you get this?

Is RED/Blue the A+/A-? Is that the A phase of the motor?

These should be duplicated on your Y axes motor. It might be a little hard to get at.


let me delete that last post and see if this clears it up. This table is how my stuff is in its current configuration.
My concern is why would the Y axis stepper work on the laser but as soon as I un plug it and plug the rotary attachment, it doesnt?

4 PIN # going to DRIVER and its color Phase label on driver 4-PIN # from Mansfield Rotary and its wire color
1 Brown A+ 1 RED
2 Blue A- 2 BLUE
3 Yellow B+ 3 GREEN
4 Black B- 4 BLACK

according to the stepper motor manufacturer, the wiring seems correct, i downloaded the wiring diagram

Also, if switch 4 on driver is at half current, does that mean its only supplying half of the 2.36 amps it is set to? would that cause the motor to not even try?

I run mine with switch 4 off all the time. Keeps it cooler.

I wouldn’t think it would take that much current to at least move an empty rotary. Never measured that.

You can measure (ohm meter) from the A+ to the A- to see if the winding is open. Same with the other field. You can do it at the cable end of the rotary. I don’t know what this should be, but not ‘open’.

Do you have it configured properly for the rotary…?

Especially the proper axes?

My dm556 driver is configured for 4.3 amps and sw4 is on, full power.

I’m going to try @micrololin suggestion. Set sw4 off, we’ll see what it does to my top speed…:grinning_face_with_smiling_eyes:


Most of my projects are burning paint of some sort of cup. I run a line interval of 0.040 so top speed is not an issue.

I can run real fast, but it’s really just good for curiosity seekers. I seem to do well around 200 - 500mm/s, so it shouldn’t be a worry. If it’ll cool my ‘motors’ it will be an easy tradeoff. I can always flip the switch the other way…