Can't change position of text

I need a little guidance regarding text positioning, I have searched but nothing I found helped.
My idea was simple, mark up some lolly sticks with plant names. I have all my origins set to centre. I measured the sticks and drew a simple rectangle the same size on the layout screen and set it to no output, aligned the laser and the beam followed my stick placed on the bed so size and alignment were fine.
I then typed the plant name and dragged it to end at the top of the stick. I was surprised to see the plant name engraved on the centre of the stick, no matter where I placed the text on screen it prints in the centre.
I tried various other methods like “apply path to text” but that was even worse. The strange thing is the X and Y coordinates of the text are updated on screen when I move it but it still prints at the centre, something is over riding my X&Y positioning, any clues.

Show us what you are getting. This is worth review: Fonts and Text - LightBurn Software Documentation

  • Align X - chooses the horizontal anchor position of the text - Left, Right, or Middle
  • Align Y - chooses the vertical anchor position of the text - Bottom, Top, or Middle. Top aligns text to the top of capital letters, and Middle aligns to roughly the middle of the capital letters. This is most useful when applying text to a path.

Hi Rick, I am familiar with the apply text to path option.
The problem is that no matter where I place the text on screen, when it burns its aligned to the centre of the bed, not the X Y position I have placed it at.

I am showing you how the text anchor setting changes how and where the text is produced.

Are you saying that no matter where you place the text on the workspace, the laser moves to the center of the laser bed and produces there? Is this true for any shape placed anywhere on the workspace?

Yes no matter where I place the text its printed centrally, I’ll have to try a shape tomorrow.

I made time to try it, and yes shapes as well as text are printed centrally around the point I have as origin, my bed size is 200 by 210 so I have origin set at 100 & 105.

BUT if I select both text and shape together, they are etched with the correct distance between them, as per the screen layout.

That is the issue. For GCode systems, 0,0, should be set to the front-left. Common Grbl Setups - LightBurn Software Documentation

Thank you, this had me very confused as you can see.
thank you for you assistance.

Our entire documentation is worth review. Here, we explain how the LightBurn coordinate system works: Coordinates and Job Origin - LightBurn Software Documentation