Can't connect to laser

I am connecting my laptop to my laser with the USB cable and was Ithe middle of using it and it just stopped working. It no longer sees the laser, can’t send it commands, can’t detect it. I have tried upgrading to the latest version of lightburn also uninstalled and reinstalled making sure to reinstall the drivers and even tried to manually add the laser, nothing has worked. When I connect to the laser with the USB cable windows beeps signifying that a device was connected. Any ideas on how to fix this?

Right-click the ‘Devices’ button - that tells LightBurn to attempt a reconnect. If it works, you should see ‘Found RDC644xG’ or similar in the bottom status bar.

If that doesn’t do anything, try re-installing the FTDI driver (from the end of the LightBurn installation). I’ve seen cases where Windows Update altered it.

Right clicking the devices buttons does not do anything. I have reinstalled lightburn and chose to reinstall the drivers and still nothing.

In the Windows device manager, when you connect, do you see the controller show up as a COM port?

When I connect the laser to the computer with the usb cable I see a new device in the device manager but it is showing an error with the device. Here are screenshots of the device manager and device properties. I tried updating the driver and uninstalling it and then reinstalling lightburn and selecting to install the FTDI drivers but everything comes up with the same error.

1-device-manager

3-driver-details