Can't engrave text

Hi I use a K40 with a mini gerbil board, I have just started with LB, but when I try to engrave text it ends up losing position and over lapping and the head starts to rattle, when engraving an image it’s fine, can anyone help please?

What speed are you using? It’s possible that with an image, if you’re asking it to go way too fast, because of the amount of code being sent to the machine, it just can’t keep up and slows down because of it. But text is very simple, so the board could match the speed you ask for, but maybe not the motors.

Hi, thanks for the response, I’ve run it speed,s 150, 100, 70 and last one was 30 and still the same, when I put shapes in like circles it engraves fine smooth and crisp, when I put a circle round text and align it up the text looks like it’s being squashed to the right side so much it overlaps and the circle engraves fine, hope this makes sense to you.WIN_20190818_11_52_21_Pro some times it just stops and I have to unplug the mini data usb and try start again.
Regards Mark

My guess is that your maximum speed in the controller is set too high, and it’s skipping when moving between shapes. Type $$ into the console window and hit enter, and copy the text it spits out here.

And, for what it’s worth, “150” isn’t a speed - you need to know what units it’s using. 150 inches/sec is way faster than 150 mm/sec, which is way faster than 150 mm/min.

Will do, the settings haven’t been changed, mm/sec
Thanks. Waiting for connection…





Starting stream

Stream completed in 0:00


Starting stream

Stream completed in 0:00


Starting stream

[MSG:Pgm End

Stream completed in 0:09











(ATC M6, pulse/ff)


(ATC Tool Td, milliseconds)


(ATC M6 Td, milliseconds)






(Softstart, milliseconds)










(Spindle freq. 0 to 15)



































(x:mm max)


(y:mm max)


(z:mm max)


(a:mm max)


(b:mm max)


These values are quite high for a K40. This is how fast the head accelerates to get up to speed. Your top speed in X is 300 mm/sec (24000 mm/min) which is fast, but maybe not excessive, but with the speed set that high, you’ll need a lower acceleration because the stepper motors lose torque when they’re going fast.

In the console, type: $120=4000 (and press enter)
Then type: $121=2500 (and press enter)

Try those values as a starting point. If it’s still skipping, drop by about 20% and try again.

1 Like

Top man, it worked, thank you so much the world just opened.
Kind Regards Mark


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.